How do I resolve allowed memory size exhausted error message?

philero

Registered
Dec 18, 2019
1
0
0
Nairobi
cPanel Access Level
Website Owner
Hi guys, I am relatively new to cpanel and has encountered the memory size exhausted error. As such I am unable to access my website and also the administration url. Both of these give me a wordpress error - 'There has been a critical error on your website. Please check your site admin email inbox for instructions.
Learn more about debugging in WordPress.'

Below are the errors I am getting on my debug log:

[19-Dec-2019 04:56:02 UTC] PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 196608 bytes) in /home/joojoost/public_html/wp-content/plugins/Ultimate_VC_Addons/modules/ultimate_tab.php on line 598
[19-Dec-2019 04:57:31 UTC] PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 12288 bytes) in /home/joojoost/public_html/wp-content/plugins/woocommerce-admin/src/API/Reports/DataStore.php on line 245
[19-Dec-2019 04:57:31 UTC] PHP Notice: Undefined index: name in /usr/local/cpanel/php/wp-cli/custom_packages/batch/command.php on line 109
[19-Dec-2019 04:57:31 UTC] PHP Notice: Undefined index: args in /usr/local/cpanel/php/wp-cli/custom_packages/batch/command.php on line 38
[19-Dec-2019 04:57:31 UTC] PHP Notice: Undefined index: name in /usr/local/cpanel/php/wp-cli/custom_packages/batch/command.php on line 109
[19-Dec-2019 04:57:31 UTC] PHP Notice: Undefined index: post in /usr/local/cpanel/php/wp-cli/custom_packages/batch/command.php on line 36
[19-Dec-2019 04:57:42 UTC] PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 12288 bytes) in /home/joojoost/public_html/wp-content/plugins/js_composer/include/classes/core/class-vc-mapper.php on line 129
[19-Dec-2019 04:57:48 UTC] PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 12288 bytes) in /home/joojoost/public_html/wp-content/plugins/js_composer/include/classes/editors/class-vc-frontend-editor.php on line 715


Can anyone assist me with this.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,304
1,250
313
Houston
Hello,

You should be able to go to cPanel>>Software>>MultiPHP INI editor and modify the PHP Memory Limit setting. If that does not resolve the issue and you do not have root access to the server, you'd need to contact your hosting provider to further assist you.
 
  • Like
Reactions: kadrin