Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

How do I setup http://IPofserver/~username -> user's website?

Discussion in 'General Discussion' started by iHost.net.nz, Oct 29, 2004.

  1. iHost.net.nz

    iHost.net.nz Well-Known Member

    Joined:
    Aug 6, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    156
    Hi,

    I recently brought a new server..

    Just wondering why I cannot access all user's websites using the IP then ~username? (without the / ?)

    For example, I am hosting someone called albahost..

    Their URL for their site (before propogation) is:
    http://208.53.138.36/~albahost/

    Although it works.. how come http://208.53.138.36/~albahost doesnt work? :confused:

    Any help would be appreciated..

    Looks like a Apache issue?

    Thanks :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. ntwaddel

    ntwaddel Well-Known Member

    Joined:
    Nov 3, 2003
    Messages:
    173
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Templeton, CA
    Make sure mod_user is loaded, and uncommented in the config

    <IfModule mod_userdir.c>
    UserDir public_html
    </IfModule>
     
  3. iHost.net.nz

    iHost.net.nz Well-Known Member

    Joined:
    Aug 6, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    156
    hi,

    I'm such a n00b.. lol

    where is the config file? :eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. ntwaddel

    ntwaddel Well-Known Member

    Joined:
    Nov 3, 2003
    Messages:
    173
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Templeton, CA
    try find / -name httpd.conf :)
     
  5. l3ean

    l3ean Registered

    Joined:
    Nov 23, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    Security

    Make sure you add the line UserDir disabled Root like:

    <IfModule mod_userdir.c>
    UserDir public_html
    UserDir disabled root
    </IfModule>

    This prevents accessing the root's home using serverip/~root
     
  6. webits

    webits Well-Known Member

    Joined:
    May 15, 2004
    Messages:
    114
    Likes Received:
    0
    Trophy Points:
    166
    Tweak Security

    Try the following go to your
    Root WHM

    go to Tweak Security

    then mod_userdir Tweak


    there might be your problem :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Jas0n

    Jas0n Registered

    Joined:
    Jun 9, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    151
    I had the same problem. For others who have the same, I fixed it by changing UseCanonicalName to off in httpd.conf.

    UseCanonicalName Off
     
  8. user.forum

    user.forum Active Member

    Joined:
    May 6, 2005
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    151
    sorry - I have tried all possible ways without any luck! any idea? :confused:
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice