Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

How do i spell check in horde?

Discussion in 'General Discussion' started by AbeFroman, Jul 10, 2003.

  1. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    318
    How do i spell check in horde?

    When I click on help it says....
    Click "Spell Check" to check your spelling.

    However I dont see a "Spell Check"

    Got any tips?

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. ekws

    ekws Member

    Joined:
    May 3, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    151
    Sorry, I don't have the exact file name or path handy...I am at my day job right now...

    You need to activate "register" the option in the .../horde/imp/config/ <some_config_file> file. If you have ispell or aspell installed you just need to tell IMP which one.

    I did this and so far the option has not been overwritten with any updates. If anyone knows how to get the view HTML option to remain after there is a WHM update...please let me know.

    Thanks...Ezra

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  3. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,504
    Likes Received:
    1
    Trophy Points:
    318
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Horde Spell Check

    Open this file:

    # /usr/local/cpanel/base/horde/imp/config/conf.php

    and scroll down to:

    /**
    ** External Utilities
    **/

    // If ispell or aspell is available, then we will provide a spelling
    // checker. If this is empty (''), null, or false, then spell checking
    // will be disabled.
    $conf['utils']['spellchecker'] = '';

    change to:

    $conf['utils']['spellchecker'] = '/usr/bin/aspell';

    This enables 'Spellcheck' to work within Horde. No restart of any services required.


    View HTML Option
    This is new one on me as I couldn't see/find it anywhere. If you know the exact path or step-by-step procedure to reach this feature, or to where it should be, please post it.

    cPanel.net Support Ticket Number: Horde spell check
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #3 Website Rob, Jul 16, 2003
    Last edited: Jul 16, 2003
  4. ekws

    ekws Member

    Joined:
    May 3, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    151
    HTML in IMP

    Thanks for filling in the blanks for me...

    To allow HTML to be displayed in the mail view for IMP; edit the the following file:

    # /usr/local/cpanel/base/horde/imp/config/mime_drivers.php


    Look for the following lines:

    /**
    * HTML driver settings
    */

    $mime_drivers['imp']['html']['inline'] = false;
    $mime_drivers['imp']['html']['icons'] = array(
    'default' => 'html.gif' );
    $mime_drivers['imp']['html']['handles'] = array(
    'text/html', 'text/richtext' );


    Change the false to true in the first line:

    $mime_drivers['imp']['html']['inline'] = true;

    Save the file and thats it. My only problem is that when ever there is an update I have to go in and change this setting again.

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  5. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    316
    Well so much for a good thing looks like someone rewrote that file and removed those lines.

    Has anyone got a new fix to get the html to work in horder now.?
     
  6. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,504
    Likes Received:
    1
    Trophy Points:
    318
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Are you sure?

    /usr/local/cpanel/base/horde/imp/config/mime_drivers.php

    <?php
    // $Horde: imp/config/mime_drivers.php.dist,v 1.1.2.6 2002/06/24 04:19:04 slusarz Exp $

    ...

    /**
    * HTML driver settings
    */

    $mime_drivers['imp']['html']['inline'] = false;
    $mime_drivers['imp']['html']['handles'] = array(
    'text/html', 'text/richtext');
    $mime_drivers['imp']['html']['icons'] = array(
    'default' => 'html.gif');
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    316
    Thanks Bob I was looking at wrong file was looking here.

    /usr/local/cpanel/base/horde/config/mime_drivers.php

    Need some sleep I guess
     
  8. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    316
    I noticed when using horde to send email it's saying To: and then the person's name. If you look at my inbox it says To:jackal@jackal.com seems to be doing that to people I send it to. Not a big issue but wasn't sure if
    that was an option in horde I messed up or ?

    Any ideas?
     
  9. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,504
    Likes Received:
    1
    Trophy Points:
    318
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice