The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How do I stop EXIM from accepting mail to anything@domain.com?

Discussion in 'E-mail Discussions' started by ed.kalk, Jul 8, 2008.

  1. ed.kalk

    ed.kalk Well-Known Member

    Joined:
    Jun 19, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Minneapolis, MN
    :confused:How do I stop EXIM from accepting mail to anything@domain.com?

    I only want to have exim accept mail to real addresses on a per domain basis.

    I'm filtering 3-4 domains and my spam filter does user verification by telneting to the mail server and performing mail from: then rcpt to: and if the mail server accepts mail to: it figures that it is a valid user and created a quarentiene DB and so on and so forth...

    There is currently 658 streams in the quarentiene DB for one of the domains! eek!

    I tested telnetting to my mail server and sure enough is accepted mail to: gshdfj@domain.com...

    I have entered :fail: in the default address and still it accepts, help!

    This is the line from /etc/vailiases/domain.com :
    *: :fail:

    Is this wrong?
     
    #1 ed.kalk, Jul 8, 2008
    Last edited: Jul 8, 2008
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    1. To set fail as the default setting for your server, go to WHM -> Server Configuration -> Tweak Settings and set the setting for Default catch-all/default address behavior for new accounts. "fail" is usually the best choice if you are getting mail attacks. to Fail.

    2. For individual accounts, in the cPanel interface, click the icon for Default Address and select "Discard with error to sender (at SMTP time)"
     
Loading...

Share This Page