Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

how do I stop exim from running as nobody?

Discussion in 'General Discussion' started by matt621, Jan 24, 2005.

  1. matt621

    matt621 Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    166
    I need to identify what accounts are hogging exim. But it's always shown as "nobody"

    How can I configure whm so that it will show which user account is using exim when I run top?
     
  2. xibalba

    xibalba Registered

    Joined:
    Dec 19, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    151
    haha, this one gave me a good chuckle. thanks.

    grep nobody /etc/passwd
    *cough*
     
  3. matt621

    matt621 Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    166
    I don't understand your reply.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    I don't understand their reply either, perfectly legitimate question :rolleyes:

    Two choices:

    1. Enable phpsuexec by selecting the option on an apache/php build, though that could cause you other problems

    2. Do the following to enable extended logging which usually reveals the scripts churning out the emails:

    WHM > Exim Configuration Editor > Advanced Mode > in the first textbox add the following line:

    log_selector = +all

    Then save it and exim will restart with extending logging enabled. Any new email sent should hopefully give you a better idea of where it is being sent from.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. matt621

    matt621 Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    166
    Thanks for the help!

    I have added the line as indicated. but where do I look for the results?
     
  6. Elliot

    Elliot Well-Known Member

    Joined:
    Jan 22, 2002
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    306
    tail -f /var/log/exim_mainlog

    I believe that is the correct dir. if not
    locate exim_mainlog
    and see where it comes up at.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice