The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How do you fix cpanel's bad phpbb forum installer?

Discussion in 'General Discussion' started by DWHS.net, Aug 10, 2004.

  1. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    I have had the phpbb installer go bad too many times to remember and of course now it's bad again.

    Anyone remember how to fix this?

    The config file is blank.

    This is a error that has been happening for years on all red hat versions and all cpanel versions I just forgot what to do I guess it's been a couple months.

    Thanks, :(
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Its quite easy actually :) Submit a bug report: http://bugzilla.cpanel.net/

    Make sure to include as many details as possible about your server ( OS, cpanel version, etc ) and steps to re-produce the error.

    If it is causing to many headaches, perhaps it would be best to remove access to the install for your clients ? There are also other installers available such as openinstaller.com and fantastico.
     
  3. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Thanks but blocking access to options that cpanel advertises is bad business. These customers expect the options that is listed.

    The problem has been ongoing for over a year but I will submit a bug ticket.

    Anyone else know how to fix it for now?
     
  4. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nirvana
    Sure do.

    Disable cPanel automatic updates and use these:
    SEE REPLY LATER IN THREAD FOR NEW PACKAGE

    Follow these directions found on http://www.openinstaller.com/download/

    Suggestion: Before following these instructions I would do a mv phpBB phpBB.old just to make sure everything is as it should be.

    To install the individual packages:
    1) Download the package into /usr/local/cpanel/addons/
    2) Run tar -jxf Package_name.tar.bz2
    3) Change directories into the newly extracted Package_name folder.
    4) Run the openinstall script (NOT THE "install" SCRIPT) via the command "./openinstall".

    And its fixed and installs phpBB 2.0.10! (If you don't turn off automatic cPanel updates the installer will be overwritten as soon as upcp runs!)
     
    #4 LP-Trel, Aug 11, 2004
    Last edited: Aug 11, 2004
  5. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
    Looks good but I cannot locate your openinstaller download and the links to the downloads in this post are empty.
     
  6. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nirvana
    Use this newly created installer that works with phpsuexec and mod_php: http://www.openinstaller.com/distfiles/phpBB/phpBB.tar.bz2

    To install the package:
    1) Download the package into /usr/local/cpanel/addons/
    2) Run tar -jxf package_name.tar.bz2
    3) Change directories into the newly extracted package_name folder.
    4) Run the openinstall script (NOT THE "install" SCRIPT) via the command "./openinstall".

    It should work fine after that. :)
     
  7. StevenC

    StevenC Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    works great A+
     
  8. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
    excellent job!

    Thanks
     
  9. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
    Just placed this on another server, Trying to use the upgrade feature to upgrade from 2.0.6 to 2.0.10.

    There is nothing in the Upgrade dropdown to upgrade yet the phpBB is installed.

    Do you have another method?
     
  10. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nirvana
    As far as I've tested it has worked well. Note: These have been 2.0.8a to 2.0.10 upgrades but, 2.0.6 should work as well.

    1) Is the addon the exact same name as the one you downloaded? (phpBB)
    2) If so what did the upgrade tell you or show you when you ran it?
     
  11. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
    Strange, Yes it is the same phpBB and the install works fine,

    When I go to upgrade there is nothing in the dropdown to upgrade
     
  12. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nirvana
    In my experience that means one of the following:

    1) Your installer is named something different.
    2) It doesn't remember you installed the other install.
    3) It thinks it is up to date.
     
  13. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
    np, thought I would mention it though.
     
  14. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nirvana
    Thank you for mentioning it but, there isn't much I can do about it. The Open Installer ties into cPanel's own addon system to make it work. If you don't see it available for upgrade then it isn't available for upgrade and there isn't much I can do.

    Now if you ran the upgrade on a 2.0.6 and its no longer showing it available for upgrade AND the script isn't up to date, that is something I can help with.
     
Loading...

Share This Page