Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

How force checking external MX in exim?

Discussion in 'E-mail Discussion' started by tlab, Mar 24, 2015.

  1. tlab

    tlab Member

    Joined:
    Nov 18, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello there,
    I have problem with hosting account created by one of my clients, who chose domain "gmail.com" as his "main domain".

    By choosing this domain this client forced Exim to treat "gmail.com" as "local domain" so every mail from all hosting accounts on this exim/whm instance is going to his hosting package... and that's big problem.

    Can we, as WHM administrators, can prevent such situations? How can I force exim to check real MX record for recipient's mail address?
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,749
    Likes Received:
    1,885
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    You should ensure the following option is disabled under the "Domains" tab in "WHM >> Server Configuration >> Tweak Settings":

    "Allow Remote Domains"

    Then, ensure the "Prevent cPanel users from creating specific domains" option is enabled.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tlab

    tlab Member

    Joined:
    Nov 18, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Michael, thanks for this tip, but this does not resolve problem in all practical cases.

    Common situation is when my client has a domain and it points to my nameservers. Client creates an hosting account, uploads files, makes multiple emails etc. - he is using my hosting service like normal user.
    After few months he decided to move to another hosting provider **but hasn't delete DNS done/unpark domain** from my hosting. This results in delivery all emails going from inside my hosting (from other clients) to wrong place - still to my server instead to the new (other's provider) one.

    What then? The best option would be to force exim to check real MX record of domain, instead of looking first to list of "local domains", right? Or maybe do you have other solution to this case (common, as I think - I have exactly this situation today)?
     
    #3 tlab, Mar 25, 2015
    Last edited: Mar 26, 2015
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,749
    Likes Received:
    1,885
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    It's important to edit those zones and select "Remote Mail Exchanger" under the "Mail Routing" section to ensure the email is handled by the remote server instead of locally. That being said, you bring up a good point. You may also want to post a feature request to address these types of cases:

    Submit A Feature Request

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice