How to Add CloudFlare Plugin in CPanel ?

piyushmaheswari

Well-Known Member
Apr 18, 2020
74
2
8
India
cPanel Access Level
Root Administrator
Sir I want to install CloudFlare Plugin in my CPanel server.
Please give me a valid command .
and also I seen many articles , there I seen that in command we have to enter Host API key and Company name , sir how to get Host API key and Company name
 

ZenHostingTravis

Well-Known Member
PartnerNOC
May 22, 2020
275
95
28
Australia
cPanel Access Level
Root Administrator

ffeingol

Well-Known Member
PartnerNOC
Nov 9, 2001
631
207
343
cPanel Access Level
DataCenter Provider
But, you can pretty much skip installing the plugin. It uses the cPanel V1 API which is shortly going to be removed (in V88 from memory). We contact CloudFlare support and they say that they do not plan to update/maintain it any longer. Same thing with mod_cloudflare (which helped with Apache logs). They now suggest using mod_remoteip, but that is more complicated to implement in cPanel ( Easiest way to install mod_cloudflare on latest CPanel since it's not available in EA? )
 

piyushmaheswari

Well-Known Member
Apr 18, 2020
74
2
8
India
cPanel Access Level
Root Administrator
But, you can pretty much skip installing the plugin. It uses the cPanel V1 API which is shortly going to be removed (in V88 from memory). We contact CloudFlare support and they say that they do not plan to update/maintain it any longer. Same thing with mod_cloudflare (which helped with Apache logs). They now suggest using mod_remoteip, but that is more complicated to implement in cPanel ( Easiest way to install mod_cloudflare on latest CPanel since it's not available in EA? )
So should I need Host API key
 

piyushmaheswari

Well-Known Member
Apr 18, 2020
74
2
8
India
cPanel Access Level
Root Administrator
Reply on this thread -
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
I've said it a few times here but as stated in CloudFlare's documentation they don't support the plugin anymore and it's using an older API version which will soon be removed as @ffeingol noted.

@piyushmaheswari I removed the referenced post because either way the answer is the same, the plugin will not be useful if they don't update it. For further information on that you must speak to CloudFlare.