Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

How to add X-AntiAbuse header?

Discussion in 'General Discussion' started by XPerties, Jun 24, 2003.

  1. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    New Jersey, USA
    As you can see in testing a php script that a spammer used on my server there are no X-AntiAbuse headers. I thought they were suppose to be on there.

    Could someone tell me how to add them or what to edit. A newbie walk through would be great.

    Thanks

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. mainarea

    mainarea Active Member

    Joined:
    Nov 18, 2002
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    156
    It's in /etc/exim.conf (this is for exim 3, cpanel 6):

    It's under the following section:
    ######################################################################
    # ROUTERS CONFIGURATION #
    # Specifies how remote addresses are handled #
    ######################################################################
    # ORDER DOES MATTER #
    # A remote address is passed to each in turn until it is accepted. #
    ######################################################################



    Code:
    lookuphost:
      driver = lookuphost
      transport = remote_smtp
    headers_add = "X-AntiAbuse: This header was added to track abuse, please include it with any abuse report\n\
                   X-AntiAbuse: Primary Hostname - $primary_hostname\n\
                   X-AntiAbuse: Original Domain - $original_domain\n\
                   X-AntiAbuse: Originator/Caller UID/GID - [$originator_uid $originator_gid] / [$caller_uid $caller_gid]\n\
                   X-AntiAbuse: Sender Address Domain - $sender_address_domain\n"
            condition = "${perl{checkspam}}"
    
    # This router routes to remote hosts over SMTP by explicit IP address,
    # given as a "domain literal" in the form [nnn.nnn.nnn.nnn]. The RFCs
    # require this facility, which is why it is enabled by default in Exim.
    # If you want to lock it out, set forbid_domain_literals in the main
    # configuration section above.
    
    literal:
      driver = ipliteral
      transport = remote_smtp
    headers_add = "X-AntiAbuse: This header was added to track abuse, please include it with any abuse report\n\
                   X-AntiAbuse: Primary Hostname - $primary_hostname\n\
                   X-AntiAbuse: Original Domain - $original_domain\n\
                   X-AntiAbuse: Originator/Caller UID/GID - [$originator_uid $originator_gid] / [$caller_uid $caller_gid]\n\
                   X-AntiAbuse: Sender Address Domain - $sender_address_domain"
            condition = "${perl{checkspam}}"
    
    end
    
    cPanel.net Support Ticket Number:
     
  3. Drake

    Drake Well-Known Member

    Joined:
    Nov 9, 2001
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    306
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    I agree. But make a spare copy of exim.conf and call it something else (exim.conf.spare) (cp -a exim.conf exim.conf.spare) in case you wreck the original conf file you can put it back.

    ~Drake P.

    www.DuraServer.net
    Web Hosting ~
    Shared & Dedicated Servers ~
    Networking ~ Linux
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #3 Drake, Jun 25, 2003
    Last edited: Jun 25, 2003
  4. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    New Jersey, USA
    This is what is inside my file, but why is it not adding the X-AntiAbuse header?


    PHP:
    ######################################################################
    #                      ROUTERS CONFIGURATION                         #
    #            Specifies how remote addresses are handled              #
    ######################################################################
    #                          ORDER DOES MATTER                         #
    #  A remote address is passed to each in turn until it is accepted.  #
    ######################################################################

    # Remote addresses are those with a domain that does not match any item
    # in the "local_domains" setting above.


    # This router routes to remote hosts over SMTP using a DNS lookup with
    # default options.

    lookuphost:
      
    driver lookuphost
      transport 
    remote_smtp
    headers_add 
    "X-AntiAbuse: This header was added to track abuse, please include it with any abuse report\n\
                   X-AntiAbuse: Primary Hostname - 
    $primary_hostname\n\
               X-AntiAbuse: Original Domain - 
    $original_domain\n\
               X-AntiAbuse: Originator/Caller UID/GID - [
    $originator_uid $originator_gid] / [$caller_uid $caller_gid]\n\
               X-AntiAbuse: Sender Address Domain - 
    $sender_address_domain\n"
        
    condition "${perl{checkspam}}"

    # This router routes to remote hosts over SMTP by explicit IP address,
    # given as a "domain literal" in the form [nnn.nnn.nnn.nnn]. The RFCs
    # require this facility, which is why it is enabled by default in Exim.
    # If you want to lock it out, set forbid_domain_literals in the main
    # configuration section above.

    literal:
      
    driver ipliteral
      transport 
    remote_smtp
    headers_add 
    "X-AntiAbuse: This header was added to track abuse, please include it with any abuse report\n\
                   X-AntiAbuse: Primary Hostname - 
    $primary_hostname\n\
               X-AntiAbuse: Original Domain - 
    $original_domain\n\
               X-AntiAbuse: Originator/Caller UID/GID - [
    $originator_uid $originator_gid] / [$caller_uid $caller_gid]\n\
               X-AntiAbuse: Sender Address Domain - 
    $sender_address_domain"
        
    condition "${perl{checkspam}}"
    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. mss6

    mss6 Member

    Joined:
    Jun 19, 2003
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    151
    The same here! X-AntiAbuse header is not added although I have the header in Router section. Any help please!

    cPanel.net Support Ticket Number:
     
  6. cass

    cass Well-Known Member

    Joined:
    Jul 17, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Argentina/USA/Mexico
    I tried this but works okey ...

    note: It does not add the headers to local mails, so, if you have domain-a.com & domain-b.com in your server, the mails between this domains will not have spam headers.

    if you havent do it ... send to OTHER account outside your server, X-headers should be there :D

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice