How to backup with encryption or other protection?

postcd

Well-Known Member
Oct 22, 2010
720
20
68
Hello,

im currently doing incremental bakcups on local drive, and i want to keep also one backup at external server (via SCP or FTP)

i want to ask what is the msot effective way when i want the files to be useless for unauthorized person which gain access to remote server?

I mean encryption, somehow reversibly crash backup, only incremental encrypted backups?


I found tool called duplicity, but it requires python 2.4 while my WHM has 2.6, i probably rather wont mess with downgrade right?
Requires: python(abi) = 2.4
Installed: python-2.6.6-52.el6.x86_64 (@updates)
Thank you
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463

lorio

Well-Known Member
Feb 25, 2004
313
22
168
cPanel Access Level
Root Administrator
I found tool called duplicity, but it requires python 2.4 while my WHM has 2.6, i probably rather wont mess with downgrade right?
You can install duplicity via yum to be compatible with CentOS (if you use CentOS as a OS).
Take a look at https://thevagabondgeek.com/backing-up-a-web-server-with-duplicity/

Thanks for pointing out my request. I posted it Januar 2009. There is always hope ;-)
 

lorio

Well-Known Member
Feb 25, 2004
313
22
168
cPanel Access Level
Root Administrator
Code:
[email protected]* [/]# yum install duplicity
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.wiredtree.com
 * epel: mirror.steadfast.net
 * extras: mirror.sanctuaryhost.com
 * rpmforge: mirror.teklinks.com
 * updates: mirror.raystedman.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package duplicity.x86_64 0:0.4.11-3.el5.rf will be updated
---> Package duplicity.x86_64 0:0.6.22-3.el6 will be an update
--> Processing Dependency: python-boto >= 0.9d for package: duplicity-0.6.22-3.el6.x86_64
--> Processing Dependency: python-GnuPGInterface >= 0.3.2 for package: duplicity-0.6.22-3.el6.x86_64
--> Processing Dependency: ncftp >= 3.1.9 for package: duplicity-0.6.22-3.el6.x86_64
--> Processing Dependency: python-paramiko for package: duplicity-0.6.22-3.el6.x86_64
--> Processing Dependency: librsync.so.1()(64bit) for package: duplicity-0.6.22-3.el6.x86_64
--> Running transaction check
---> Package librsync.x86_64 0:0.9.7-15.el6 will be installed
---> Package ncftp.x86_64 2:3.2.4-1.el6 will be installed
---> Package python-GnuPGInterface.noarch 0:0.3.2-6.el6 will be installed
---> Package python-boto.noarch 0:2.27.0-1.el6 will be installed
---> Package python-paramiko.noarch 0:1.7.6-1.el5.rf will be installed
--> Processing Dependency: python(abi) = 2.4 for package: python-paramiko-1.7.6-1.el5.rf.noarch
--> Processing Dependency: python-crypto for package: python-paramiko-1.7.6-1.el5.rf.noarch
--> Running transaction check
---> Package python-crypto.x86_64 0:2.0.1-22.el6 will be installed
---> Package python-paramiko.noarch 0:1.7.6-1.el5.rf will be installed
--> Processing Dependency: python(abi) = 2.4 for package: python-paramiko-1.7.6-1.el5.rf.noarch
--> Finished Dependency Resolution
Error: Package: python-paramiko-1.7.6-1.el5.rf.noarch (rpmforge)
           Requires: python(abi) = 2.4
           Installed: python-2.6.6-52.el6.x86_64 (@updates)
               python(abi) = 2.6
           Available: python-2.6.6-51.el6.x86_64 (base)
               python(abi) = 2.6
 You could try using --skip-broken to work around the problem
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
duplicity-0.4.11-3.el5.rf.x86_64 has missing requires of python(abi) = ('0', '2.4', None)
duplicity-0.4.11-3.el5.rf.x86_64 has missing requires of python-GnuPGInterface
sendmail-cf-8.14.4-8.el6.noarch has missing requires of sendmail = ('0', '8.14.4', '8.el6')
It looks a bit messy.
I see CentOS 5 and Centos 6 packages.
What is your OS?

The problem here is that you have python packages installed from different repositories.
You have installed rpmforge as a repository. I would get rid of rpmforge and stick to epel if possible.

Take a look at CentOS / RHEL / Scientific Linux 6 Enable & Install EPEL Repo to learn how to handle repostories and find the installed packages from different repositories.
 

postcd

Well-Known Member
Oct 22, 2010
720
20
68
thank you for help fixing it, i see i had el5 duplicity, while my os is Centos 6.x 64bit
i removed rpmforge and did yum clean-all; then yum install duplicity and i think it works. except it says "ssh: Could not resolve hostname: Name or service not known" when connecting remote server with duplicity.
 
Thread starter Similar threads Forum Replies Date
R Backups 1
benito Backups 2
H Backups 3
M Backups 3
bgarrant Backups 1