The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to change in definitive exim delivery queue parameter -q30m to -q5m

Discussion in 'General Discussion' started by ebrandi, Jan 14, 2005.

  1. ebrandi

    ebrandi Registered

    Joined:
    Jan 2, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi guys,

    I'm running Cpanel 9.9.8-R118 ina FreeBSD 5.3 machine, and are trying to change exim delivery queue parameter from -q30m to -q5m.

    I'm doing this editing /scripts/restartsrv_exim and restarting mail server, but every time that comand /scripts/upcp run, archive restartsrv_exim get -q30m back :(

    I have made changes in:

    /usr/local/etc/rc.d/040exim.sh
    /usr/local/etc/rc.d/exim.sh

    Without any success.

    Someone can tell me where i need to make my change to prevent this rollback ?

    Best regards

    Edson
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    WHM > Tweak Settings > Number of minutes between mail server queue runs

    Unless FreeBSD WHM doesn't have the option.
     
  3. ebrandi

    ebrandi Registered

    Joined:
    Jan 2, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thks chirpy, i cant find this option in my "WHM > Tweak Settings" :(
     
  4. patreanand

    patreanand Registered

    Joined:
    Nov 30, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Yes indeed the option is there
    Goto WHM => Tweak Settings => Mail area
    The option 'Number of minutes between mail server queue runs (default is 60).:'.

    :)
     
  5. DigitalN

    DigitalN Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    420
    Likes Received:
    1
    Trophy Points:
    18
    The file to adjust, at least on linux would be

    /etc/sysconfig/exim

    QUEUE=5m
    DAEMON=yes

    Restart exim.

    Not sure where its hiding on cPanel BSD servers though, sorry about that, have to change the setting in whm and perhaps look around for the runtime config file or add the parameter to your rc.conf.
     
    #5 DigitalN, Mar 13, 2005
    Last edited: Mar 13, 2005
Loading...

Share This Page