The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to change MX to use google email

Discussion in 'E-mail Discussions' started by salvatore333, Jun 6, 2006.

  1. salvatore333

    salvatore333 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Customer wants us as a web host but use google as his email host.

    I ask him to give me google's mx settings and he gives me this:


    Mail Server Priority Value:

    ASPMX.L.GOOGLE.COM. 10
    ALT1.ASPMX.L.GOOGLE.COM. 20
    ALT2.ASPMX.L.GOOGLE.COM. 30
    ASPMX2.GOOGLEMAIL.COM. 40
    ASPMX3.GOOGLEMAIL.COM. 50


    Would somebody be kind enough to please give me a step by step on how to edit his DNS Zone in WHM to get this to properly work. Not sure if I also have to remove it from localdomains and add it to remotedomains and restart bind. Instructions would be very appreciated,

    Thanks again, Sal
     
  2. salvatore333

    salvatore333 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    After making the first change via the customers cpanel I think I figured the rest out. Do I still need to delete it from /etc/localdomains and add it to /etc/remotedomains?

    Thanks alot, Sal
     
  3. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    If I'm understanding what you're trying to do, that's not going to work.

    What you've done is basically say 'send emails destined for address@domain.com to google'... their servers aren't going to know anything about domain.com and so they'll refuse it.

    What you need to do is either setup his entire domain to forward all email to his google email address, or just setup all email addresses on his domain to forward to his google account.
     
  4. Almighty

    Almighty Member

    Joined:
    Apr 20, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Actually they will, as I assume the customer is using Gmail Hosted which lets you use gmail for your domain.
     
  5. salvatore333

    salvatore333 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Do I still need to delete it from /etc/localdomains and add it to /etc/remotedomains?
     
  6. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18

    One thing I've learned... never 'assume' ;)

    I've had people ask for things like "can I get an email address that ends in microsoft.com?"... so I have a tendency to think the worst :D
     
  7. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18

    Nope. Just set your MX entries accordingly.

    Where the localdomains/remotedomains comes into play is when you're setting up a secondary server in case the primary goes down.
     
  8. salvatore333

    salvatore333 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Thank you very much Lyttek. The customer said it is working fine.
     
  9. bmcgrail

    bmcgrail Well-Known Member

    Joined:
    Dec 8, 2003
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6

    No, you still need to remove it from localdomains. If the customer puts a form on their website to be emailed to user@domain and that domain is in the localdomains file exim won't look for an MX record, it will just try and deliver the message. Same is true if people try and send email to domain using your box as their outgoing SMTP server.
     
  10. salvatore333

    salvatore333 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    For some reason it's not even in /etc/localdomains

    Thanks for your response.
     
  11. bmcgrail

    bmcgrail Well-Known Member

    Joined:
    Dec 8, 2003
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    If you used the change MX function from cpanel it would have taken it out of localdomains for you. It when people edit the zone directly that they have to manually do this task.
     
  12. Norman

    Norman Well-Known Member

    Joined:
    Sep 20, 2004
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    This owrked for me too.. When I changed the MX via Cpanel it didn't remove it and I was having issues routing.. but this seemed to work perfectly

    Thanks guys
     
  13. satu

    satu Registered

    Joined:
    Oct 8, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Am a customer who requested help from my host to change the mx records. They were kind enough to send me a screen shot of the changes made but google still said that there was error in the settings.

    Is there anything I need to do on my part? I've changed the "managed MX records under email settings" but no help. My host asked me to contact google. Which email in google do i send to? :D

    Maybe i should send my hosting company here to read the forums a bit more :lol:
     
  14. levelsupport

    levelsupport Well-Known Member

    Joined:
    Oct 7, 2006
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    As far as it has tested and worked for me, you just have to do the following simple things.
    say your domain is email.com
    goto whm > edit dns zone > email.com
    their you will see your mx with priority 0 and value email.com.
    change it to
    priority 10 and value ASPMX.L.GOOGLE.COM.
    and same way create new mx records

    check the screenshots i am attaching.
     

    Attached Files:

  15. mohit

    mohit Well-Known Member

    Joined:
    Jul 12, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sticky On Internet
    should be removed from localdomain too

    hi,
    as said earlier i think the domain name which is using goolge mail services should be removed from localdomain and added to remotedomains so mails originating from your server are able to reach this domain.

    see ya,
    mohit
     
Loading...

Share This Page