how to change primary nameservers?

Bahram0110

Well-Known Member
Dec 12, 2007
45
0
56
hi,
how can I change primary name servers in whm (dns's reported by server)
I have root access
cpanel latest release, centos 5.x

after change nameserver ip's, intodns.com says:
Missing nameservers
reported by your
nameservers
 

kimper

Member
Oct 26, 2010
12
0
51
Montreal, Canada
Hello.
You have just to open the WHM as a root,
Go to Basic cPanel/WHM Setup in Server Configuration
You'll find lines to configure the hostname and nameservers.
Do not forget to add an A entry for each one, and add a Child DNS entry in your registrar interface.
 

Bahram0110

Well-Known Member
Dec 12, 2007
45
0
56
Hello.
You have just to open the WHM as a root,
Done!

Go to Basic cPanel/WHM Setup in Server Configuration
Done!

You'll find lines to configure the hostname and nameservers.
where!? In whm 11.28 this option is removed from this section, I think.

Do not forget to add an A entry for each one
Done!

and add a Child DNS entry in your registrar interface.
Done!

all these was Done before creating topic.
I also run this command :
perl -p -i -e 's/ns1.olddomain.com/ns1.newdomain.com/g' /var/named/*.db
perl -p -i -e 's/ns2.olddomain.com/ns2.newdomain.com/g' /var/named/*.db

steal intodns says:

Error Mismatched NS records WARNING: One or more of your nameservers did not return any of your NS records.

Error Multiple Nameservers ERROR: Looks like you have less than 2 nameservers. According to RFC2182 section 5 you must have at least 3 nameservers, and no more than 7. Having 2 nameservers is also ok by me.

Error Nameservers are lame ERROR: looks like you have lame nameservers. The following nameservers are lame:
xx.xx.xx.xx
xx.xx.xx.yy

Error Missing nameservers reported by your nameservers You should already know that your NS records at your nameservers are missing, so here it is again:

ns1.newdomain.com.
ns2.newdomain.com.


Warn SOA MNAME entry WARNING: SOA MNAME (ns1.olddomain.com) is not listed as a primary nameserver at your parent nameserver!