The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to copy (or Bcc send) Outgoing mail via Server-side coding?

Discussion in 'E-mail Discussions' started by NatanZ, Feb 18, 2012.

  1. NatanZ

    NatanZ Member

    Joined:
    Feb 3, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello guys,

    I got this tiny issue,
    My Incoming mail is forwarded to my backup mail which is OK.
    But I cannot forward Sent mail.

    Therefor, I'm asking - Is there a code or something Server-sided to copy (or just Bcc send) outgoing mail?

    Hope you understood, thanks.

    BTW, I'm new to cPanel... :D
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
  3. NatanZ

    NatanZ Member

    Joined:
    Feb 3, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,

    I need this code I'm almost sure:
    I just didn't understand where to put the code above (my /etc/ folder in my FTP server in empty, please explain me.

    Thanks ahead!!!
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    So you do not have a file called /etc/cpanel_exim_system_filter on your server? If you do not, please try saving the WHM > Exim Configuration Editor or WHM > Exim Configuration Manager area first to see if that file creates. It should exist on your system.
     
  5. NatanZ

    NatanZ Member

    Joined:
    Feb 3, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hey Tristan,

    I found it on WHM, but I cannot logon to my root FTP server (or 'root' shouldn't have FTP?).
    To be more specific, when I try to log-in - it founds the 'root' user, but my password is incorrect (I filled my WHM 'root's password). It's weird.

    Is there a way to what I need via VHM panel?

    Thanks,
    Natan.
     
  6. ruzbehraja

    ruzbehraja Well-Known Member

    Joined:
    May 19, 2011
    Messages:
    383
    Likes Received:
    7
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    if using root you need to use SFTP

    Port should be 22 instead of 21
     
  7. NatanZ

    NatanZ Member

    Joined:
    Feb 3, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hey, It says:

    Status: Connecting to 107.80.222.7...
    Response: fzSftp started
    Command: open "root@107.80.222.7" 22
    Error: Network error: Connection refused
    Error: Could not connect to server

    (I changed the real IP address for security reasons)

    Any help please?
     
  8. ruzbehraja

    ruzbehraja Well-Known Member

    Joined:
    May 19, 2011
    Messages:
    383
    Likes Received:
    7
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Looks like a firewall is blocking it.

    Before that, you may want to check:
    WHM >> FTP Server Configuration >> Allow Logins with Root Password is enabled.

    Also check your CSF and Local Machines Firewall / Anti virus settings.
     
  9. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    The root user shouldn't be logging into FTP and the instructions were for SSH rather than sFTP or FTP for root login. Please log into SSH using a client such as putty for Windows or terminal in Mac OS X.
     
  10. NatanZ

    NatanZ Member

    Joined:
    Feb 3, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I do not have option Allow Logins with Root Password, awkward.

    This is the WHM: WHM 11.28.87
    CENTOS 5.5 x86_64 virtuozzo on vps

    I tried PuTTY,
    it says Network error: connection refused.
     
  11. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Were you trying port 22 for the connection or what command were you using precisely?

    Of note, you would need to learn how to use SSH so long as you are administering the machine. You might want to get ahold of your datacenter, NOC or provider to have them help with this.
     
  12. NatanZ

    NatanZ Member

    Joined:
    Feb 3, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I put: Host name: IP.IP.IP.IP, Port: 22 as default.
    Weird...
     
  13. storminternet

    storminternet Well-Known Member

    Joined:
    Nov 2, 2011
    Messages:
    462
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Please make sure that ssh port hasn't been changed. If it is changed to customized port you would need to use it for sftp also.
     
Loading...

Share This Page