The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how to disable anon ftp

Discussion in 'General Discussion' started by miami_g, Jun 14, 2002.

  1. miami_g

    miami_g Active Member

    Joined:
    Dec 28, 2001
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    please let me know how to kill anon ftp for an entire server

    thankyou and please be kind to newbie


    el_g
     
  2. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    You can disable anonymous ftp for your entire server by commenting out the ftp entry in /etc/passwd.
     
  3. miami_g

    miami_g Active Member

    Joined:
    Dec 28, 2001
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    anon ftp remains active, or appears to be after commenting out
    the ftp entry in /etc/passwd

    this what i have::

    #ftp:x:14:50:FTP User: /home/ftp:

    did i miss something?
     
  4. Brownie

    Brownie Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    heres what I used to disable anon-ftp.

    edit /etc/proftpd.conf

    this is my&Anonymous&&/Anonymous&:

    &Anonymous ~ftp&
    UseFtpUsers on
    RequireValidShell off

    User ftp
    Group ftp
    # We want clients to be able to login with &anonymous& as well as &ftp&
    #UserAlias anonymous ftp

    &Limit LOGIN&
    DenyAll
    &/Limit&
    # Limit the maximum number of anonymous logins
    MaxClients 10

    # We want 'welcome.msg' displayed at login, and '.message' displayed
    # in each newly chdired directory.
    DisplayLogin welcome.msg
    DisplayFirstChdir .message

    # Limit WRITE everywhere in the anonymous chroot
    &Limit WRITE&
    DenyAll
    &/Limit&

    &/Anonymous&
     
  5. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    hmm.. I've edited my proftp.conf like shown above but I can't still access as anonymous.

    I see
    bin
    etc
    lib
    ...
    but I'd like that you can't see anything as anonymous.. is that possible?

    thx,

    dave.
     
  6. eter4

    eter4 Well-Known Member

    Joined:
    Feb 16, 2002
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    What about just going into Tweak FTP settings and click on Disable Anon FTP
     
  7. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    I did, but if I refresh, anon FTP is still enabled.. I can't disable it there.. ¿?
     
  8. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    Did you remember to restart proftpd?

    /etc/rc.d/intit.d/proftpd stop

    then

    /etc/rc.d/init.d/proftpd start
     
  9. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    hmm strange.. I've restarted proftpd in whm.. now I did it like you told me.. after proftpd stop I tried to connect per ftp and it worked perfect.. strange.. and I can still acces as anon..
     
  10. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    hemm.. still strange: I switched to Pure-ftpd and disabled anon ftp.. status after restart: enabled... grr..
    then I switched back to proftpd and disabled anon again. status: disabled.. huuh? cool!
    but I can't although connect as anon.. the hell.. don't know whats wrong.. ?!
     
  11. cyberwisdom

    cyberwisdom Well-Known Member

    Joined:
    Jun 2, 2003
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Did you get this resolved? I have the same freakin problem. I've tried everything you've tried and can still access the same folders you see.

    The good thing is that some accounts were successfully disabled but there are still several that I can login via ANON FTP.

    Let me know if you or someone found a fix.

    Thanx...

    cPanel.net Support Ticket Number:
     
  12. elor

    elor Active Member

    Joined:
    Apr 20, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    In WHM,

    If it show's disabled, enable it. Wait for ftp to restart, then disable it again.

    I had the same - showed disabled but was enabled. This fixed it for me. (pureftp)

    cPanel.net Support Ticket Number:
     
  13. cyberwisdom

    cyberwisdom Well-Known Member

    Joined:
    Jun 2, 2003
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Thanx!! Worked like a charm.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page