How to disable cgi-script in server

Sumanto09

Member
Mar 17, 2017
20
0
1
Kolkata, India
cPanel Access Level
Root Administrator
Firefox_Screenshot_2017-05-26T06-11-31.165Z.png

Hello,

I want to disable cgi-script running from all accounts.

But when creating a new package from Home>>Packages>>Add a Package.

The option in "Settings" >> CGI Access is ticked(default).

I want to disable this option.

Thank you.
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,219
463
Hello,

You can disable the following option in "WHM >> Basic WebHost Manager® Setup" to disable the automatic cgi-bin script alias:

Automatically create a cgi-bin script alias. This setting can be individually overridden during account creation.

Additionally, you can disable the following option in your packages via "WHM >> Packages >> Edit a Package":

"CGI Access"

Please also see the following post:

Disable cgi scripts even using fcgi as php handler.

Thank you.
 

Sumanto09

Member
Mar 17, 2017
20
0
1
Kolkata, India
cPanel Access Level
Root Administrator
Have you disabled it as explained above?
Right now I'm disabling the use of CGI by "CGI Access" in "WHM >> Packages >> Edit a Package".

My point is whenever a new package is created the "CGI Access" is selected by default this I don't want.

I want the "CGI Access" disabled in "Add a Package" better fully disabled.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,219
463