The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to disable email completely?

Discussion in 'E-mail Discussions' started by tuxfan, Aug 21, 2008.

  1. tuxfan

    tuxfan Member

    Joined:
    Oct 1, 2006
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    between chair and keyboard
    Is there some way to disable email for a certain cPanel a/c completely?

    I have a cPanel a/c who has been sending bulk mails from my server. So I have suspended their site from root WHM. They are requesting to re-enable at least HTTP.

    Is this possible?

    I don't want them to use POP/SMTP/IMAP/Webmail/PHP Mail
     
  2. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    Hate to answer a question with a question... but why would you want to keep them at all if you don't trust them?
     
  3. Gamer4u

    Gamer4u Member

    Joined:
    Feb 14, 2006
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    That's not an answer or a helpful advancement of the question. :(
     
  4. eyecool

    eyecool Member

    Joined:
    May 5, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I'm facing the same issue. My server load is constantly off the charts due to dozens of concurrent processes that look like this:
    qwplayer 0 3.5 0.0 /usr/sbin/exim -Mc 1KYEk1-0001yK-Ie

    I know the culprit is my user account called qwplayer. I deleted the MX record a few days ago, hoping that would cut out the spam (over 1000 undeliverable messages every time I check mail que) or whatever is causing this account to go bezerk with exim. That didn't work.

    I don't want to delete the entire account. I just want to disable email for it. I also modified the account to have 0 users, but I do have a lot of /~user accounts I don't want to delete.
     
  5. eyecool

    eyecool Member

    Joined:
    May 5, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Sadly, I had to disable exim on the entire server for the cpus to return to normal.

    I've been dealing with this issue for some time now. cPANEL is up to date, so is the system software... I think the issue is with that one specific account where so much spam is being sent to a a few user accounts, it spirals the serer out of control and it eventually crashes. (server was crashing about once a day and usually in the morning)

    I installed csf tonight, but didn't have the time to get in to it...

    Eager to see if anyone knows how to disable email on an account level!

    Thanks,

    eyecool
     
  6. Murtaza_t

    Murtaza_t Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    476
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    cPanel Access Level:
    Website Owner
    Hello,

    Just remove the domain from the /etc/localdomains and that should do the trick.
     
  7. MadMax1228

    MadMax1228 Member

    Joined:
    Aug 26, 2008
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Enable the Firewall on your VPS (if you have one). I did it last night by mistake but I can tell you for sure it works like a charm!:)
     
Loading...

Share This Page