The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to Disable Mandatory SSL (Web Login to WHL)

Discussion in 'Security' started by ukw, Jan 24, 2011.

  1. ukw

    ukw Registered

    Joined:
    Jan 24, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    after restarting cpanel from the command line (/etc/init.d/cpanel restart) the main web login for whm and cpanel displays this message:

    "SSL encryption is required for access to this server."


    SSL seems to be poorly, as when we follow the login using SSL link, the connection eventually times out in the browser.

    Would anyone happen to know how to remove the requirement for SSL web login from the command line? (Fedora Linux system)

    Many Thanks

    Darren
     
  2. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    You can do this by editing /var/cpanel/cpanel.config with your favorite shell text editor and changing the following entry:

    Code:
    requiressl=1
    Change the "1" to a "0", and save the changes. You may also need to edit the following entry:

    Code:
    alwaysredirecttossl=1
    If the value is a "1", change to a "0". Next, make sure to run the following command:

    Code:
    # /usr/local/cpanel/whostmgr/bin/whostmgr2 --updatetweaksettings
    This command will put any changes made to the /var/cpanel/cpanel.config file into effect.

    The above settings in /var/cpanel/cpanel.config correspond to the following settings in the WebHost Manager in Main >> Server Configuration >> Tweak Settings:

    • Always redirect to SSL
    • Require SSL
     
  3. ukw

    ukw Registered

    Joined:
    Jan 24, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi Jared,

    many thanks for the quick response. I'll try the file edit now.

    Darren
     
  4. ukw

    ukw Registered

    Joined:
    Jan 24, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi Jared,

    perfect! Quick response and a quick fix - great service.

    Many Thanks

    Darren
     
  5. nmavra

    nmavra Member

    Joined:
    Nov 9, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Changing this option from the GUI doesn't do anything.
    Is it bugged? I'm still redirected to https.

    Does changing it from console make a difference?
    thanks
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Try restarting cPanel in root SSH to see if that works:

    Code:
    /etc/init.d/cpanel restart
    Sometimes saving settings in WHM > Tweak Settings doesn't seem to restart cPanel and WHM (whostmgrd) for the changes to take effect.
     
  7. davidolaj

    davidolaj Registered

    Joined:
    May 8, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Please I can't find this file (/var/cpanel/cpanel.config) on my cPanel VPS server.... Is there any problem on my server cPanel?

    Because the SSL settings not working from my WHM > Tweak Settings!
     
  8. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    So when you are logged in as root user in SSH, that file doesn't exist? Can you run this command?

    Code:
    ls -lah /var/cpanel/cpanel.config
    If that file doesn't exist, it certainly should.
     
Loading...

Share This Page