Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to disable MB String Input in cpanel 58

Discussion in 'General Discussion' started by Marcel Corzo, Oct 15, 2017.

  1. Marcel Corzo

    Marcel Corzo Registered

    Joined:
    Oct 15, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Colombia
    cPanel Access Level:
    Website Owner
    Hi. I'm trying to install a drupal theme in a byehost hosting service, but it says that I have to disable MB String Input: "Multibyte string input conversion in PHP is active and must be disabled. Check the php.ini mbstring.http_input setting. Please refer to the PHP mbstring documentation for more information.". I didn't find the php.ini file. So I found on the cpanel version 58.0.31 the link "alter php config", I found the MB string input set to "auto", I tried to put another value to disable it but it always gets an error "error please try again". I tried the values "0", "off", and always I get the error. Please help me which value can I put here. Thank you very much for your help.

    Regards,

    Marcel
     
  2. Marcel Corzo

    Marcel Corzo Registered

    Joined:
    Oct 15, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Colombia
    cPanel Access Level:
    Website Owner
    Hi again. I could changed it with the value "pass". But now I get this error:
    "Multibyte string output conversion in PHP is active and must be disabled. Check the php.ini mbstring.http_output setting. Please refer to the PHP mbstring documentation for more information.". And that variable is not available through my c-panel. How could I change that?
     
  3. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    618
    Likes Received:
    192
    Trophy Points:
    43
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    This used to work, but I haven't tried it for a couple of years.......

    You could try and add the following to your htaccess file:
    Code:
    # PHP 5, Apache 1 and 2.
    <IfModule mod_php5.c>
      php_flag magic_quotes_gpc                 off
      php_flag magic_quotes_sybase              off
      php_flag register_globals                 off
      php_flag session.auto_start               off
      php_value mbstring.http_input             pass
      php_value mbstring.http_output            pass
      php_flag mbstring.encoding_translation    off
    </IfModule>
    
    If that doesn't work, I suggest you ask your web host for help in changing the PHP ini settings for your site.
     
    #3 rpvw, Oct 15, 2017
    Last edited: Oct 15, 2017
  4. cPWilliamL

    cPWilliamL cP Technical Analyst II
    Staff Member

    Joined:
    May 15, 2017
    Messages:
    257
    Likes Received:
    29
    Trophy Points:
    103
    Location:
    America
    cPanel Access Level:
    Root Administrator
    Hi Marcel,

    How you go about disabling this differs depending on your PHP handler and on your EasyApache version. If using CGI or suPHP as your PHP handler, try adding the following to a `.user.ini' file in your domain's document root:
    Code:
    mbstring.http_input = pass
    You should also be able to confirm via a phpinfo page to ensure the drupal theme is accurately reporting the mbstring directive settings:
    PHP: phpinfo - Manual
     
Loading...

Share This Page