how to disable non-delivery reports in Exim

0884094

Member
Nov 14, 2013
14
6
3
cPanel Access Level
Root Administrator
Hi friends, is there a way to disable non-delivery reports in Exim?

My server hosts ~400 domains and I allow my users to set up email forwarding only, with catch-all forwarding as the default... so like [all]@example.com => example @ gmail.com. Periodically we'll get swamped with thousands of spam emails to [email protected] which are then forwarded to gmail.com, which rejects them -- and counts them against our reputation -- and then they all get backscattered, further hurting our reputation.

I'm already doing everything I can to validate at SMTP-time and reject any emails possible at that time, so the only remaining problems are the async forwards which have a valid forward rule set up but the remote server ends up rejecting after the fact.

I'd be happy to just disable NDR entirely... or if I can make them go to a system address that I control instead of the original-from, that'd help.

Currently I've blocked them (I think) by setting up a custom SPF record for ns1.example.com which doesn't allow sending from any valid IP, so the NDR from [email protected] is flagged... and then I have set "(*) Scan outgoing messages for spam and reject"... which seems to be blocking NDRs from leaving my server but I think it's messing up other stuff too... if there was a clean Exim config option, I'd use that.

Thanks!
 

LucasRolff

Well-Known Member
May 27, 2013
128
74
28
cPanel Access Level
Root Administrator
Hi,

Please do not use catch-all, please do not blindly forward emails to gmail.

You're asking for trouble, and sure you'll get backscattered - that's the beauty - which in itself is enough reason to not do what you're trying to do.