The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to Disable SMTP in Exim?

Discussion in 'E-mail Discussions' started by wimp, May 20, 2006.

  1. wimp

    wimp Well-Known Member

    Joined:
    Jul 13, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    16
    hi all,
    is htere a way to disable SMTP in exim? I don't like to let customers using mail.hisdomain.com to sending out e-mails. (of course, pop3 should be available)
    Alos the webmail should not be able to send mails.

    Thanks for advice.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    To stop users from being able to relay through the server, enable the SMTP Tweak in WHM > Tweak Security - if you use your own iptables firewall it won't work though and you'll have to implement what it does yourself from:

    /scripts/smtpmailgidonly

    AS for webmail - disable it in WHM > Tweak Settings.
     
  3. wimp

    wimp Well-Known Member

    Joined:
    Jul 13, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    16
    hi,
    as i have APF installed it does probably not work. Running:
    /scripts/smtpmailgidonly
    will disale the SMTP server for outgoing mails?
    How to enable it again? (just in case...)

    Thanks a lot
     
  4. wimp

    wimp Well-Known Member

    Joined:
    Jul 13, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    16
    chirpy how to reverse "/scripts/smtpmailgidonly" ??


    thanks
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Just run:

    /scripts/smtpmailgidonly off
     
  6. wimp

    wimp Well-Known Member

    Joined:
    Jul 13, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    16
    sorry chirpy but this does the same thing as in WHM tweak settings and customer can still send out e-mails with. mail.theredomain.com
    What i like to do is disable completaly SMTP so nobody can send -emils though the server.

    I was told to do the following:
    Uncomment the following in exim and chmod antirelayed to 000:
    ---------------------------
    begin authenticators

    fixed_plain:
    driver = plaintext
    public_name = PLAIN
    server_condition = "${perl{checkuserpass}{$1}{$2}{$3}}"
    server_set_id = $2

    fixed_login:
    driver = plaintext
    public_name = LOGIN
    server_prompts = "Username:: : Password::"
    server_condition = "${perl{checkuserpass}{$1}{$2}}"
    server_set_id = $1
    --------------------------


    but it does not block anything. I also delete port 25 in APF (egress/outgress) but i am still able to send mails though the server.


    any other way?

    thanks a lot
     
    #6 wimp, May 31, 2006
    Last edited: May 31, 2006
Loading...

Share This Page