The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to disbable exim sender address verification

Discussion in 'General Discussion' started by almecho, Jan 19, 2006.

  1. almecho

    almecho Member

    Joined:
    Feb 6, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    exim seems to be rejecting mail that it should definately not be rejecting, and disabling sender address verification seems to be the easiest way to address my particular problem.

    Anyone know what needs to be added/changed to exim.conf in order to turn it off ?
     
  2. rs-freddo

    rs-freddo Well-Known Member

    Joined:
    May 13, 2003
    Messages:
    832
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    You can turn it off from WHM.
     
  3. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    You can do that, but it sounds like you have more problems then that. Reinstall exim and check it. Sender verify is a simple thing and it works.
     
  4. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    I have been having issues n a few servers as well. Check this out. This is from my log:

    2006-01-20 03:09:37 H=(pling.tourism-software.co.uk) [213.232.93.15] F=<susan.grange@xxxxxxxx.co.uk> temporarily rejected RCPT <silkweb@yyyyyyyy.ie>: Could not complete sender verify callout

    However, when I go to dnsstuff.com and do an email address test, teh address is perfectly valid.

    I am seeing this on several servers and might very well be disalbing these. This only seems to be a problem with the callouts, but simply disabling the callout portion of the option does not seem to improve things.
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It's mostly going to be senders that don't have their DNS setup appropriately or their email servers don't accept email for addresses that they send from. If everything is setup correctly a mail server that relays an email also should accept that same address for relaying - this sounds obvious and is a tennant for SMTP to work. However, some appear to set up their mail servers so that that is not the case. It's those cases where you find the problem.

    It's up to you as to whether you want to accept email from servers that are not setup correctly. If you do, then you'll have to disable sender callouts. If you don't, then you could try to contact the sender by some means and ask them to correct their mail servers.

    More information about sender callouts on the exim site:
    http://www.exim.org/exim-html-4.50/doc/html/spec_39.html#IX2587
     
  6. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    Good info!

    Though what is not clear is how adding teh /callout changes the verify = sender. verify = sender always worked fine, and now that we have the callout option,it seems to be pickier. Bottoim line is that the client sees that it is a valid email and doesn't give a hoot that their DNS might be set up wrong, just that its a valid email address and the email should be let through.

    Jon
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    verify = sender
    This simply does a lookup on the sender domain to ensure that an MX record exists and resolves

    verify = sender/callout
    This takes an extra step to actually connect to the SMTP server resolved to above and attempts to start an SMTP conversation to attempt delivery to the sender up to and including the RCPT stage. If that fails, then the senders email setup is invalid.

    You can turn off sender callout verification in WHM > Exim Configuration Editor > if you want to.
     
  8. djblamire

    djblamire Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    16
    I have had this problem too, so went into WHM/Exim Configuration Editor to take it off.

    I noticed though, while it updated the settings, I got the following error/message:

    2006-06-02 07:49:14 Exim configuration error in line 895 of /etc/exim.conf.buildtest:
    user mailman was not found

    Exim version 4.52 #1 built 16-Aug-2005 04:57:36
    Copyright (c) University of Cambridge 2005
    Berkeley DB: Sleepycat Software: Berkeley DB 4.2.52: (September 21, 2004)
    Support for: iconv() PAM Perl OpenSSL Content_Scanning Old_Demime
    Lookups: lsearch wildlsearch nwildlsearch iplsearch dbm dbmnz
    Authenticators: cram_md5 plaintext spa
    Routers: accept dnslookup ipliteral manualroute queryprogram redirect
    Transports: appendfile/maildir autoreply pipe smtp
    Configuration file has an invalid syntax. Please try again.

    Any idea what the problem may be, or how to fix it ?

    Thanks in advance,
    Daniel
     
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
Loading...

Share This Page