The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how to downgrade perl 5.10,1 to 5.8.8

Discussion in 'General Discussion' started by ayankhan, Sep 9, 2014.

  1. ayankhan

    ayankhan Member

    Joined:
    Sep 8, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello today when I setup my VPS I installed perl 5.10.1 but I need perl 5.8.8,

    how can we downgrade perl on VPS having CENTOS 6.5 x86_64

    waiting for urgent reply.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It's important to understand that cPanel & WHM servers include multiple Perl environments. Please ensure you review the following document to better understand how it works:

    Perl Environments and Modules

    Thank you.
     
  3. ayankhan

    ayankhan Member

    Joined:
    Sep 8, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks I gone through the link you provided and another question pop up in my mind is that when will perl 5.8.8 vanish means to say in past their was a perl version 5.6.1 and now its not available for installation, when will this happen with 5.8.8. when will its life ends?

    Thanks.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    The EOL date doesn't always correspond with when it's no longer used or made available. Since you are on CentOS 6, I'd advise keeping the version of the Perl binary included with your OS (Perl 5.10). What's not working with this version that will work on 5.8.8?

    Thank you.
     
Loading...

Share This Page