The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to enable curl when it's installed?

Discussion in 'General Discussion' started by Cemtey, Dec 25, 2007.

  1. Cemtey

    Cemtey Well-Known Member

    Joined:
    Aug 19, 2007
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    How to enable curl when it's installed? [SOLVED]

    Well I've installed curl by automatic system install.

    Now I'd need to enable CURL and CURL+SSL
    How to do that?
    Should I compile it with php? ./configure --with-curl script tells me:
    batch# ./configure no such file or directory
     
    #1 Cemtey, Dec 25, 2007
    Last edited: Dec 25, 2007
  2. Amit Deshmukh

    Amit Deshmukh Well-Known Member

    Joined:
    Jul 1, 2007
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Its Simple

    Contact your host - or if you have your own and it's redhat add by rpm.

    You need to recompile PHP with '--with-curl' '--with-openssl'

    If you have cPanel and WHM server, login to WHM.

    Goto Software / Update Apache

    Accept the default and also select

    PHP Version 4.4.4

    Curl
    Curl SSL
    DOM XSLT
    GD
    GetText
    IMAP Module
    MB String
    OpenSSL Support
    FreeType Support

    Then click "Start Build"

    The build will take 10-30 minutes depending on the system.

    Let us know if the error persist.

    Regards,
    Amit
    Back in Action
     
  3. Amit Deshmukh

    Amit Deshmukh Well-Known Member

    Joined:
    Jul 1, 2007
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Its Simple

    Try throw shell

    bash# /script/easyapache

    This will ask you the options.

    Good Luck

    Regards,
    Amit
    Back in Action
     
  4. Cemtey

    Cemtey Well-Known Member

    Joined:
    Aug 19, 2007
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    An Error has occurred, please make sure that apache is running and restartable.

    It didn't finished it. And apache is running just fine.
    What now?
     
  5. Cemtey

    Cemtey Well-Known Member

    Joined:
    Aug 19, 2007
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    !! 'make' failed with exit code '512' !!
    !! Restoring original working apache !!
    !! Executing '/scripts/initfpsuexec' !!
    !! Executing '/scripts/initsslhttpd' !!
     
  6. Amit Deshmukh

    Amit Deshmukh Well-Known Member

    Joined:
    Jul 1, 2007
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Its Simple

    Uncomment the curl line in your php.ini file to enable curl

    There is only one way to truely compile curl *without* SSL and that is to
    explicitly call configure like this:

    ./configure --without-ssl

    If not, the configure script will check for SSL stuff in the default
    places. --enable-ssl is mainly used for telling the configure script where to
    look.

    Also, make sure you remove the 'config.cache' file between the configure
    invokes so that all values are actually re-evaluated and not picked from the
    cache.

    Let us if the error persist.

    Regards,
    Amit
    Back in Action
     
  7. Cemtey

    Cemtey Well-Known Member

    Joined:
    Aug 19, 2007
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Do you even know what your talking about?1? I just told you that your other way gave me errors TWICE

    and now your telling me bunch of nonsense.

    Only line in php.ini containing CURL is this:

    extension=php_curl.dll

    and it doesn't have ; mark in front of it.

    CURL still doesn't work!


    And I need cURL+SSL also.
     
  8. Amit Deshmukh

    Amit Deshmukh Well-Known Member

    Joined:
    Jul 1, 2007
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Its Simple

    Hold on you said :-

    Well I've installed curl by automatic system install.

    Now I'd need to enable CURL and CURL+SSL
    How to do that?
    Should I compile it with php? ./configure --with-curl script tells me:
    batch# ./configure no such file or directory
    Reply With Quote

    Now, you say that I made a mistake. First you need to make sure what are you exactly doing.

    Also the command /scripts/easyapache does nothing but recomplies the thing

    Regards,
    Amit
    Back in Action
     
  9. Cemtey

    Cemtey Well-Known Member

    Joined:
    Aug 19, 2007
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Thanks.

    I just got like :confused: after your last post since I didn't understand why are you going after php.ini when we're in middle of trying to get WHM apache update working.

    Now after some time of messing around with this thing I finally got cURL and cURL+SSL enabled correctly. Thanks to your help afcorse, since I didn't know about that nice place in WHM. :)

    I belive I've just got it working by trying again via /scripts/easyapache
    This time I unchecked Perl, zendmulti and used php 4.4.7 instead of
    installing php ver 4.4.4

    Overview from the error I had before:

    Now when I got it working it gave me output like this:

    Thanks again and this case is solved. :)
     
Loading...

Share This Page