How to enable FXP in Pure-ftpd?

KiDoubleD

Member
Aug 27, 2004
7
0
151
How to enable FXP in Pure-ftpd or Pro-ftpd?

Can someone tell me how I can enable FXP transfers in Pure-ftpd or Pro-ftpd? Also need to know how to limit the number of logins for each ftp account. I would like each user to only be able to have 2 ftp sessions at a time.
Thanx in advance.
 
Last edited:

zye

Well-Known Member
Dec 6, 2002
122
4
168
inside
/etc/sysconfig/pure-ftpd

you can change userlimit idle time etc...

i also did not find the option for

--allowuserfxp

to enable

the process if you do ps-aux should be
/usr/sbin/pure-authd -s -w /var/run/ftpd.sock -r /usr/sbin/pureauth

but i have
/usr/sbin/pure-authd -s /var/run/ftpd.sock -r /usr/sbin/pureauth

anyone knows how to enable FXP ?
 

zye

Well-Known Member
Dec 6, 2002
122
4
168
found out how to enabe FXP on pureftpd

open
pico /etc/sysconfig/pure-ftpd

go to the end of the file and add under

# read the fine manual or ask the mailing-list.

--allowuserfxp

STRG+X

Y

save it and restart pure-ftpd and FXP is working