The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to enable Optimize Website for all the users/IPs?

Discussion in 'EasyApache' started by byazid, Nov 25, 2013.

  1. byazid

    byazid Registered

    Joined:
    Nov 25, 2013
    Messages:
    0
    Likes Received:
    0
    Trophy Points:
    0
    cPanel Access Level:
    Root Administrator
    Hi,

    I've been trying days to work this out but failed over and over again. I've been using my VPS for last 10 months and this is the first time i am having hard times with apache.

    I badly need to enable gzip compression for my website and which is why i enabled 'DEFLATE" through 'Easy apache".
    However, after several attempt i failed to work gzip compression out. I've read in so many forum that enabling the "DEFLATE' will enable the option in cpanel 'Optimize Website' for any of the users under my VPS server but it did not actually showed up. I never got the option 'Optimize Website' .

    i've followed below guide :
    SolidServers.ca » Blog Archive » How to enable mod_deflate globally in cPanel/WHM
    but it did not work.

    Also, Below is the error log i got when i tried to uncheck the DEFLATE..

    Code:
    If the browser window is closed or stopped the build will continue in the background.
    The build output should start shortly...
    
    Distilled successfully
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1385398470' !!
    !!
    Output from '/bin/sh -c "ulimit -a"':
    core file size          (blocks, -c) 1048576
    data seg size           (kbytes, -d) unlimited
    scheduling priority             (-e) 0
    file size               (blocks, -f) unlimited
    pending signals                 (-i) 771812
    max locked memory       (kbytes, -l) 32
    max memory size         (kbytes, -m) unlimited
    open files                      (-n) 1024
    pipe size            (512 bytes, -p) 8
    POSIX message queues     (bytes, -q) 819200
    real-time priority              (-r) 0
    stack size              (kbytes, -s) 10240
    cpu time               (seconds, -t) unlimited
    max user processes              (-u) 1024
    virtual memory          (kbytes, -v) unlimited
    file locks                      (-x) unlimited
    !!
    !! Creating backup of working apache in '/usr/local/apache.backup'. !!
    !! Symlink encountered (/usr/local/apache/etc), preserving target (conf)... !!
    
    !! Backup of working apache complete. !!
    Checking that all tarballs are present and up to date.
    Checking that all packages are present and up to date.
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: p3plmirror01.prod.phx3.secureserver.net
    * extras: p3plmirror01.prod.phx3.secureserver.net
    * updates: p3plmirror01.prod.phx3.secureserver.net
    Setting up Install Process
    No package zlib1-devel available.
    Package expat-devel-2.0.1-11.el6_2.x86_64 already installed and latest version
    Package gettext-0.17-16.el6.x86_64 already installed and latest version
    No package automake19 available.
    No package libopenssl0-dev available.
    Package expat-2.0.1-11.el6_2.x86_64 already installed and latest version
    Package bison-2.4.1-5.el6.x86_64 already installed and latest version
    No package autoconf261 available.
    Package libidn-devel-1.18-2.el6.x86_64 already installed and latest version
    No package gmake available.
    Package libidn-1.18-2.el6.x86_64 already installed and latest version
    No package libtool-libltdl-devel available.
    No package libopenssl0 available.
    No package openssl-dev available.
    Package libtool-2.2.6-15.5.el6.x86_64 already installed and latest version
    Package patch-2.6-6.el6.x86_64 already installed and latest version
    No package libz-devel available.
    No package libltdl3-devel available.
    No package libltdl available.
    No package libopenssl0.9.7-static-devel available.
    No package pam-dev available.
    Package libtool-ltdl-devel-2.2.6-15.5.el6.x86_64 already installed and latest version
    No package libopenssl0.9.7-devel available.
    No package libltdl-devel available.
    Package sed-4.2.1-10.el6.x86_64 already installed and latest version
    Package lsof-4.82-4.el6.x86_64 already installed and latest version
    No package krb5-dev available.
    No package ca_root_nss available.
    Package flex-2.5.35-8.el6.x86_64 already installed and latest version
    No package glibc-dev available.
    No package expat-dev available.
    No package libstdc++-devel.x64_64 available.
    Package 1:make-3.81-20.el6.x86_64 already installed and latest version
    No package libstdc++-dev.x86_64 available.
    Package libtool-ltdl-2.2.6-15.5.el6.x86_64 already installed and latest version
    No package libssl-dev available.
    No package libopenssl0-devel available.
    No package ssl-dev available.
    No package lex available.
    Package autoconf-2.63-5.1.el6.noarch already installed and latest version
    Resolving Dependencies
    There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
    The program yum-complete-transaction is found in the yum-utils package.
    --> Running transaction check
    ---> Package automake.noarch 0:1.11.1-1.2.el6 will be updated
    ---> Package automake.noarch 0:1.11.1-4.el6 will be an update
    ---> Package compat-expat1.i686 0:1.95.8-8.el6 will be installed
    ---> Package compat-expat1.x86_64 0:1.95.8-8.el6 will be installed
    ---> Package coreutils.x86_64 0:8.4-19.el6 will be updated
    --> Processing Dependency: coreutils = 8.4-19.el6 for package: coreutils-libs-8.4-19.el6.x86_64
    ---> Package coreutils.x86_64 0:8.4-19.el6_4.2 will be an update
    ---> Package cpp.x86_64 0:4.4.6-4.el6 will be updated
    ---> Package cpp.x86_64 0:4.4.7-3.el6 will be an update
    ---> Package e2fsprogs-devel.x86_64 0:1.41.12-12.el6 will be updated
    ---> Package e2fsprogs-devel.x86_64 0:1.41.12-14.el6_4.2 will be an update
    --> Processing Dependency: libcom_err-devel = 1.41.12-14.el6_4.2 for package: e2fsprogs-devel-1.41.12-14.el6_4.2.x86_64
    --> Processing Dependency: e2fsprogs-libs = 1.41.12-14.el6_4.2 for package: e2fsprogs-devel-1.41.12-14.el6_4.2.x86_64
    ---> Package gcc.x86_64 0:4.4.6-4.el6 will be updated
    --> Processing Dependency: gcc = 4.4.6-4.el6 for package: gcc-gfortran-4.4.6-4.el6.x86_64
    ---> Package gcc.x86_64 0:4.4.7-3.el6 will be an update
    --> Processing Dependency: libgomp = 4.4.7-3.el6 for package: gcc-4.4.7-3.el6.x86_64
    ---> Package gcc-c++.x86_64 0:4.4.6-4.el6 will be updated
    ---> Package gcc-c++.x86_64 0:4.4.7-3.el6 will be an update
    ---> Package glibc.i686 0:2.12-1.80.el6_3.4 will be updated
    --> Processing Dependency: glibc = 2.12-1.80.el6_3.4 for package: nscd-2.12-1.80.el6_3.4.x86_64
    --> Processing Dependency: glibc = 2.12-1.80.el6_3.4 for package: glibc-common-2.12-1.80.el6_3.4.x86_64
    --> Processing Dependency: glibc = 2.12-1.80.el6_3.4 for package: glibc-headers-2.12-1.80.el6_3.4.x86_64
    ---> Package glibc.x86_64 0:2.12-1.80.el6_3.4 will be updated
    ---> Package glibc.i686 0:2.12-1.107.el6_4.4 will be an update
    ---> Package glibc.x86_64 0:2.12-1.107.el6_4.4 will be an update
    ---> Package glibc-devel.i686 0:2.12-1.80.el6_3.4 will be updated
    --> Processing Dependency: glibc-devel = 2.12-1.80.el6_3.4 for package: glibc-static-2.12-1.80.el6_3.4.x86_64
    ---> Package glibc-devel.x86_64 0:2.12-1.80.el6_3.4 will be updated
    ---> Package glibc-devel.i686 0:2.12-1.107.el6_4.4 will be an update
    ---> Package glibc-devel.x86_64 0:2.12-1.107.el6_4.4 will be an update
    ---> Package krb5-devel.x86_64 0:1.9-33.el6_3.2 will be updated
    ---> Package krb5-devel.x86_64 0:1.10.3-10.el6_4.6 will be an update
    --> Processing Dependency: krb5-libs = 1.10.3-10.el6_4.6 for package: krb5-devel-1.10.3-10.el6_4.6.x86_64
    --> Processing Dependency: libkdb5.so.6()(64bit) for package: krb5-devel-1.10.3-10.el6_4.6.x86_64
    ---> Package libgcc.i686 0:4.4.6-4.el6 will be updated
    ---> Package libgcc.x86_64 0:4.4.6-4.el6 will be updated
    ---> Package libgcc.i686 0:4.4.7-3.el6 will be an update
    ---> Package libgcc.x86_64 0:4.4.7-3.el6 will be an update
    ---> Package libstdc++.x86_64 0:4.4.6-4.el6 will be updated
    ---> Package libstdc++.x86_64 0:4.4.7-3.el6 will be an update
    ---> Package libstdc++-devel.x86_64 0:4.4.6-4.el6 will be updated
    ---> Package libstdc++-devel.x86_64 0:4.4.7-3.el6 will be an update
    ---> Package openssl.x86_64 0:1.0.0-25.el6_3.1 will be updated
    ---> Package openssl.x86_64 0:1.0.0-27.el6_4.2 will be an update
    ---> Package openssl-devel.x86_64 0:1.0.0-25.el6_3.1 will be updated
    ---> Package openssl-devel.x86_64 0:1.0.0-27.el6_4.2 will be an update
    ---> Package pam-devel.x86_64 0:1.1.1-10.el6_2.1 will be updated
    ---> Package pam-devel.x86_64 0:1.1.1-13.el6 will be an update
    --> Processing Dependency: pam = 1.1.1-13.el6 for package: pam-devel-1.1.1-13.el6.x86_64
    ---> Package zlib.x86_64 0:1.2.3-27.el6 will be updated
    ---> Package zlib.x86_64 0:1.2.3-29.el6 will be an update
    ---> Package zlib-devel.x86_64 0:1.2.3-27.el6 will be updated
    ---> Package zlib-devel.x86_64 0:1.2.3-29.el6 will be an update
    --> Running transaction check
    ---> Package coreutils-libs.x86_64 0:8.4-19.el6 will be updated
    ---> Package coreutils-libs.x86_64 0:8.4-19.el6_4.2 will be an update
    ---> Package e2fsprogs-libs.i686 0:1.41.12-12.el6 will be updated
    --> Processing Dependency: e2fsprogs-libs = 1.41.12-12.el6 for package: e2fsprogs-1.41.12-12.el6.x86_64
    ---> Package e2fsprogs-libs.x86_64 0:1.41.12-12.el6 will be updated
    ---> Package e2fsprogs-libs.i686 0:1.41.12-14.el6_4.2 will be an update
    --> Processing Dependency: libcom_err = 1.41.12-14.el6_4.2 for package: e2fsprogs-libs-1.41.12-14.el6_4.2.i686
    ---> Package e2fsprogs-libs.x86_64 0:1.41.12-14.el6_4.2 will be an update
    ---> Package gcc-gfortran.x86_64 0:4.4.6-4.el6 will be updated
    ---> Package gcc-gfortran.x86_64 0:4.4.7-3.el6 will be an update
    --> Processing Dependency: libgfortran = 4.4.7-3.el6 for package: gcc-gfortran-4.4.7-3.el6.x86_64
    ---> Package glibc-common.x86_64 0:2.12-1.80.el6_3.4 will be updated
    ---> Package glibc-common.x86_64 0:2.12-1.107.el6_4.4 will be an update
    ---> Package glibc-headers.x86_64 0:2.12-1.80.el6_3.4 will be updated
    ---> Package glibc-headers.x86_64 0:2.12-1.107.el6_4.4 will be an update
    ---> Package glibc-static.x86_64 0:2.12-1.80.el6_3.4 will be updated
    ---> Package glibc-static.x86_64 0:2.12-1.107.el6_4.4 will be an update
    ---> Package krb5-libs.x86_64 0:1.9-33.el6_3.2 will be updated
    ---> Package krb5-libs.x86_64 0:1.10.3-10.el6_4.6 will be an update
    ---> Package libcom_err-devel.x86_64 0:1.41.12-12.el6 will be updated
    ---> Package libcom_err-devel.x86_64 0:1.41.12-14.el6_4.2 will be an update
    ---> Package libgomp.x86_64 0:4.4.6-4.el6 will be updated
    ---> Package libgomp.x86_64 0:4.4.7-3.el6 will be an update
    ---> Package nscd.x86_64 0:2.12-1.80.el6_3.4 will be updated
    ---> Package nscd.x86_64 0:2.12-1.107.el6_4.4 will be an update
    ---> Package pam.x86_64 0:1.1.1-10.el6_2.1 will be updated
    ---> Package pam.x86_64 0:1.1.1-13.el6 will be an update
    --> Running transaction check
    ---> Package e2fsprogs.x86_64 0:1.41.12-12.el6 will be updated
    ---> Package e2fsprogs.x86_64 0:1.41.12-14.el6_4.2 will be an update
    --> Processing Dependency: libss = 1.41.12-14.el6_4.2 for package: e2fsprogs-1.41.12-14.el6_4.2.x86_64
    ---> Package libcom_err.i686 0:1.41.12-12.el6 will be updated
    ---> Package libcom_err.x86_64 0:1.41.12-12.el6 will be updated
    ---> Package libcom_err.i686 0:1.41.12-14.el6_4.2 will be an update
    ---> Package libcom_err.x86_64 0:1.41.12-14.el6_4.2 will be an update
    ---> Package libgfortran.x86_64 0:4.4.6-4.el6 will be updated
    ---> Package libgfortran.x86_64 0:4.4.7-3.el6 will be an update
    --> Running transaction check
    ---> Package libss.x86_64 0:1.41.12-12.el6 will be updated
    ---> Package libss.x86_64 0:1.41.12-14.el6_4.2 will be an update
    --> Finished Dependency Resolution
    
    Error: Protected multilib versions: libstdc++-4.4.7-3.el6.x86_64 != libstdc++-4.4.6-4.el6.i686
    Error: Protected multilib versions: zlib-1.2.3-29.el6.x86_64 != zlib-1.2.3-27.el6.i686
    You could try using --skip-broken to work around the problem
    ** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
    frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0
    sendmail-cf-8.14.4-8.el6.noarch has missing requires of sendmail = ('0', '8.14.4', '8.el6')
    !! ensure() rc was '0', exit status was '256', perl '$?' was '0', exit sig '0', core dump: '0', shell '$?' was '1' !!
    
    !! Simulating failed Cpanel::SysPkgs as per 'simulate-failed-syspkgs' flag !!
    
    !! Could not ensure pkglist 'glibc, zlib1-devel, compat-expat1.i686, expat-devel, gettext, automake19, libstdc++.x86_64, libopenssl0-dev, gcc-c++, expat, openssl, glibc-devel, zlib-devel, zlib, bison, compat-expat1, glibc-devel.i686, autoconf261, libidn-devel, gmake, libidn, openssl-devel, automake, coreutils, libtool-libltdl-devel, libgcc, libopenssl0, openssl-dev, libtool, patch, libz-devel, libgcc.i686, libltdl3-devel, libltdl, libopenssl0.9.7-static-devel, pam-dev, libtool-ltdl-devel, libopenssl0.9.7-devel, libltdl-devel, fileutils, e2fsprogs-devel, sed, lsof, krb5-dev, ca_root_nss, flex, glibc-dev, expat-dev, krb5-devel, libstdc++-devel.x64_64, make, libstdc++-dev.x86_64, glibc.i686, libtool-ltdl, libssl-dev, libstdc++-devel.x86_64, pam-devel, cpp, gcc, libopenssl0-devel, ssl-dev, lex, autoconf' !!
    !! The server's system package manager, 'YUM', failed. !!
    
    !!
    This is the command that failed: yum -y install glibc zlib1-devel compat-expat1.i686 expat-devel gettext automake19 libstdc++.x86_64 libopenssl0-dev gcc-c++ expat openssl glibc-devel zlib-devel zlib bison compat-expat1 glibc-devel.i686 autoconf261 libidn-devel gmake libidn openssl-devel automake coreutils libtool-libltdl-devel libgcc libopenssl0 openssl-dev libtool patch libz-devel libgcc.i686 libltdl3-devel libltdl libopenssl0.9.7-static-devel pam-dev libtool-ltdl-devel libopenssl0.9.7-devel libltdl-devel fileutils e2fsprogs-devel sed lsof krb5-dev ca_root_nss flex glibc-dev expat-dev krb5-devel libstdc++-devel.x64_64 make libstdc++-dev.x86_64 glibc.i686 libtool-ltdl libssl-dev libstdc++-devel.x86_64 pam-devel cpp gcc libopenssl0-devel ssl-dev lex autoconf !!
    
    !!
    Since EasyApache was unable to resolve it automatically you should: 1) Manually run the failed YUM command (shown above) via SSH 2) See if your particular error is addressed at [url=http://go.cpanel.net/eaerror]EasyApache: Known Issues[/url] 3) Resolve the YUM problem manually 4) Re-run EasyApache !!
    
    !! Please visit [url=http://go.cpanel.net/eaerror]EasyApache: Known Issues[/url] for help with this error. !!
    
    !! Restoring original working apache !!
    
    !! Executing '/scripts/initsslhttpd' !!
    !! Restarting 'httpd' ... !!
    !! 'httpd' restart complete. !!
    Building global cache for cpanel...Done
    !! Executing '/scripts/initfpsuexec' !!
    !! Executing '/scripts/initsslhttpd' !!
    !! Executing '/scripts/update_apachectl' !!
    Compiling report...
    Sending report. As some of the attached files may be quite large, this could take a few minutes. Thanks for your patience.
    !! If you want to create a support ticket with cPanel regarding this please reference 'BuildAP Report Id': '12353683' !!
    
    Report processed.
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1385398470' 
    WebHost Manager_error.png

    Is there any one can help me on this?

    Thanks
     

    Attached Files:

  2. MikeDVB

    MikeDVB Well-Known Member
    PartnerNOC

    Joined:
    Jun 4, 2008
    Messages:
    212
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Indiana, USA
    I never had to do anything but simply enabling the option in EasyApache and then going to 'Optimize Website' in cPanel. You may need to check the feature list applied to the cPanel account to make sure that feature is enabled.
     
Loading...

Share This Page