The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to enable SCP?

Discussion in 'General Discussion' started by aingaranweb, Jan 9, 2006.

  1. aingaranweb

    aingaranweb Well-Known Member

    Joined:
    Mar 23, 2003
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto, Ontario
    I have root access, but SCP is currently disabled... I'm trying to transfer from 1 server to another... On the 2nd server, I'm whm trying to run the multiple account transfer, and it says SCP disabled on server 1.

    How do I enable it?

    I have root access on both servers.
     
  2. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    I think, this problem is due to the ssh access of the root. Does the root has direct ssh access on the server?, if no try using the wheel user and the correct ssh port. May be it will help u
     
  3. aingaranweb

    aingaranweb Well-Known Member

    Joined:
    Mar 23, 2003
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto, Ontario
    No direct root access via SSH. I disabled that myself. I have a wheel group user that has SU- access.

    I've done it before, it says SCP disabled.
     
  4. wildbrn

    wildbrn Member

    Joined:
    Apr 21, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Check what is permission of scp command

    ls -l /usr/bin/scp

    If its 0 then make it 755

    also check if scp is installed

    which scp
     
  5. Estrac

    Estrac Well-Known Member

    Joined:
    Nov 18, 2005
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    is because, root needs to have access to the server

    i enable it when i want to make multiple restores

    then, i edit again sshd_config disble root login, restart sshd and we finish :- )

    Regards

    estrac
     
Loading...

Share This Page