The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to enable temporary URL to access domains

Discussion in 'EasyApache' started by Sarath Kumar R, Oct 18, 2016.

Tags:
  1. Sarath Kumar R

    Sarath Kumar R Registered

    Joined:
    Oct 18, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi guys,

    My server is running with ea4 with cgi as handler. Please refer the below snippet for more details:

    ===
    ~]# /usr/local/cpanel/bin/rebuild_phpconf --current
    DEFAULT PHP: ea-php56
    ea-php55 SAPI: cgi
    ea-php56 SAPI: cgi
    ea-php70 SAPI: cgi
    ====

    Mod_ruid is enabled on the server. I want to access the domain using temporary URL http://xx.xx.xx.xx/~username/

    While accessing I am getting 404. Please verify the same from below URL:

    ==
    - Removed -
    ==

    So some one please let me know how to enable this feature in Easyapache 4
     
    #1 Sarath Kumar R, Oct 18, 2016
    Last edited by a moderator: Oct 18, 2016
  2. leonep

    leonep Well-Known Member

    Joined:
    Nov 18, 2014
    Messages:
    46
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Pescara
    cPanel Access Level:
    Root Administrator
    may be there is enabled in WHM-->Security Center-->Apache mod_userdir Tweak
     
    Sarath Kumar R likes this.
  3. Sarath Kumar R

    Sarath Kumar R Registered

    Joined:
    Oct 18, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Nope its not enabled.

    On the page I am getting below pasted message

    mod_userdir is disabled
    Web server processes on this system currently run as the user. For security reasons, mod_userdir is disabled in this case. Consequently, no changes you make in this interface will take effect until mod_userdir is enabled. To use mod_userdir, you must disable mod_ruid2 and mpm_itk and recompile EasyApache.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    SysSachin likes this.
  5. Sarath Kumar R

    Sarath Kumar R Registered

    Joined:
    Oct 18, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    cPanel Access Level:
    Root Administrator
    I have tried disabling mod_ruid. When I am disabling mod_ruid I am getting not supported error on browser. Some please help.

    Can someone please suggest workaround or a fix my issue.
     
    #5 Sarath Kumar R, Oct 18, 2016
    Last edited by a moderator: Oct 19, 2016
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
Loading...

Share This Page