The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to enable xsl extension

Discussion in 'Workarounds and Optimization' started by milvers, Feb 28, 2013.

  1. milvers

    milvers Registered

    Feb 28, 2013
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Website Owner
    Hi cPanel,

    The hosting provider did not help me to solve my problem so I though I could ask question on this cPanel forum. The question I am trying to solve is "How to enable xsl php extension" so that the light weight CMS I am using need xxl php extension to able to operate smoothly.

    I had tried to search within the PEAR search engine in my cPANEL login account and dosent seem to find the xsl. Also I was unable to manually enable xsl extension as there is no php.ini in my php folder.

    Do I have to create php.ini to enable the extension or is there different and correct way of enable such php extension?

    I really appreciate anybody to guide me or provide me links to how to enable the php extension in my hosting cPanel account.
  2. stdout

    stdout Well-Known Member

    Apr 10, 2003
    Likes Received:
    Trophy Points:
    Nelspruit, Mpumalanga, South Africa
    cPanel Access Level:
    Root Administrator
    Do you have SSH +Compiler Access?
    You will be able to Load 3rd party PHP Extensions using a customized PHP.ini

    1. The PHP XSL Extensions needs to be compiled.
    2. The compiled PHP Extension can then be loaded in a custom php.ini under your DocumentRoot.
    3. The XSL Extension requires libXML -- does your existing PHP installation have it?

    I assume the shared hosting server that you're on is running suPHP.
    Simply upload a default php.ini -- then add the neccesary XSL entries in order to get PHP to load them.
    On suPHP systems you can tell Apache to use your custom php.ini by simply adding the below line to your ,htaccess file

    suPHP_ConfigPath /home/username/path/to/php.ini
    If you havent already, do a bit of reading on the official XSL website.
    The fact that you have only user-level access does make this a bit more trickier. If there's a will there's a way..

    IMO - it would be ALOT easier to just contact support and request that they recompile PHP with the XSLT module.
    cPanel's Easyapache has XSL bundled -- it just needs to be "ticked" (after being approved by support, ofcourse).

    Good Luck.
    PHP: Requirements - Manual
    PHP: Installation - Manual
  3. MaestriaNick

    MaestriaNick Well-Known Member

    Aug 6, 2008
    Likes Received:
    Trophy Points:
    You can enabled xsl if libxsl already compiled in. You dont have php.ini in your document root and xsl still not enabled means, it is not recompiled. So, the host need to recompile php with libxsl, which they can easily do via easyapache. Unless you have no root access, you will need to contact your host for this.

Share This Page