The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How To Fix Mysql ? [merged]

Discussion in 'General Discussion' started by Radio_Head, May 19, 2005.

Thread Status:
Not open for further replies.
  1. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    How to fix this please

    /usr/bin/mysqladmin: connect to server at 'localhost' failed error: 'Access denied for user 'root'@'localhost' (using password: YES)' mysql has failed, please contact the sysadmin (result was "mysql has failed").

    Thank you
     
  2. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    bump .
     
  3. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    I fixed the myqsl.sock error and password error (10 hours)

    Finally I fixed the problem , after trying in 1 billion ways .
    (thanks to haze for his idea on irc)


    If you have myqsl.sock errors and password problems too with 4.0 or 4.1 try this (for me worked!)

    I had mysql 4.0

    #service mysql stop

    #rpm -qa | grep -i mysql

    you should have something like this

    MySQL-devel-4.0.24-0
    MySQL-server-4.0.24-0
    MySQL-shared-compat-4.0.24-0
    MySQL-embedded-4.0.24-0
    MySQL-bench-4.0.24-0
    MySQL-shared-4.0.24-0
    MySQL-client-4.0.24-0


    remove all packages with
    #rpm -e package

    starting from this package MySQL-embedded-4.0.24-0

    When all will be removed try to restart mysql from WHM , (yes you have understood !)

    It should START ! (don't ask me WHY!)

    Now go on whm and change mysql root password . (it should change without errors)

    Now go on tweak settings and change to 4.1
    wait 30 seconds and click on system update as suggested from whm

    Now you will have 4.1 working without .sock and password errors !!!
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Please don't cross-post onto every MySQL thread you can find, it is considered rude. IF someone can help, they'll chip in, if not you'll either need to get help from your datacentre, cPanel or hire someone.
     
  5. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    Ok (nice after 1098 posts it's the first time someone moderate one of my posts :) )

    Now it's starting the time for censoring in these places :) ?

    There are tons of post regarding the mysql problem
    and I don't uderstand why I cannot open another as the others. I opened a new post to put in BIG evidence a possible solution (infact just now I received 1 pm with someone having my same problem) .

    I decided to put in evidence opening an appropriate title (fixed) because there are hundred of people with the sock/password mysql problem , unsolved from days (DarKorb ?!?!)

    However it's not important , important that I fixed the problem on my server and I hope it will help to fix the problem for all.
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The problem was that you asked the same question on at least 8 threads - please don't do that. If you have a question, feel free to ask it on an existing relevant thread or start a new one, but don't cross-post. Your problem is no more or less important than anyone elses. It's not censorship, it's asking people to be polite and respect internet etiquette.

    I'm glad you sorted your problem out.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page