a24uall

Active Member
Feb 4, 2010
27
0
51
India
Hello,

I am totally in confusion as my managed VPS provider refused to help me..with tomcat custom configuration.
Am trying to find a solution for :
1) /http://myfamilymeet.com/w3search.myfam --> Wont work
2) /http://myfamilymeet.com:8080/w3search.myfam --> Will work with port 8080

In this same VPS I have another domain a24uall.info
/http://a24uall.info/w3search.a24/ --> works

The conf change I made is in /usr/local/apache/conf/jk.conf
++++++++++++++++++++++++
ProxyPass /http://a24uall.info:8080/
ProxyPassReverse /http://a24uall.info:8080/
++++++++++++++++++++++++

But my real problem starts here..
When I give the same conf settings like above to any other domain in /usr/local/apache/conf/jk.conf it wont work..

See
/http://myfamilymeet.com/w3search.myfam --> wont work..
Hop I hv explained the problem correctly..Can any one here plz help ?
 
Last edited by a moderator:

a24uall

Active Member
Feb 4, 2010
27
0
51
India
Another update
When I put in the below in /usr/local/apache/conf/jk.conf
=====================
ProxyPass /http://myfamilymeet.com:8080/
ProxyPassReverse /http://myfamilymeet.com:8080/
=====================
instead of
=====================
#ProxyPass /http://a24uall.info:8080/
#ProxyPassReverse /http://a24uall.info:8080/
======================

then /http://myfamilymeet.com/w3search.myfam/]Family Search will load succesfully..

So what I infer from this is that /usr/local/apache/conf/jk.conf file does not allow more than one entry to be added like the above..
I tried adding entries for both the domain but it never worked

Any one who knws abt this proxy setting to be customised to use for all the domains..in my server ??
 
Last edited by a moderator:

Miraenda

Well-Known Member
Jul 28, 2004
243
5
168
Coralville, Iowa USA
cPanel Access Level
Root Administrator
Try putting the code from jk.conf into the /usr/local/apache/conf/userdata/std/2/username/domain.com/ location (change username and domain.com to the username and domain in question). Check in the include, distill it, rebuild Apache and restart it to see the results. You should be able to put the include for both domains in their own separate userdata folders in that path.

Of note, you could get this working if you've placed your war files into /usr/local/jakarta/tomcat/webapps by copying the extracted war files into /home/username/public_html/folder location (the war file's extracted folder name), then restarting Tomcat. The reason these aren't working on port 80 is that the folders aren't extracted into public_html I imagine, so only port 8080 can find them due to their current location.
 

a24uall

Active Member
Feb 4, 2010
27
0
51
India
Success

haii all
thanks for all ur help

Finally I figured out the solution, thought to share that with all...:):)
Apache never routed the request to tomcat properly which caused the problem
U can see the solution here :
/http://webhostingdevelopment.com/forum/?p=737
 
Last edited by a moderator: