The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to fix the "from email" and "return-path" for users?

Discussion in 'E-mail Discussions' started by rhm.geerts, Sep 8, 2011.

  1. rhm.geerts

    rhm.geerts Active Member

    Joined:
    Jul 29, 2008
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Maastricht
    cPanel Access Level:
    Root Administrator
    Since some time I've got the problem that email will be send out this way:

    Then I'm going to look at the headers and find this:
    Now the second problem can be fixed by using the -f parameter, if present in the software, but in this case, this software has no -f parameter option.

    These are my 2 questions:

    1.) How can I remove that Nobody stuff in the first post, so that it will only say "Sender: John Doe [John@domain.com]" and nothing else?

    2.) Is there a way to fix it that users which have no -f parameter set, will automatically get their domain name or main email address as return-path instead of nobody@hotname?

    Thank you for thinking with me.
     
  2. rhm.geerts

    rhm.geerts Active Member

    Joined:
    Jul 29, 2008
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Maastricht
    cPanel Access Level:
    Root Administrator
    Nobody any clue?
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I think you'll find this section useful:

    WHM > Service Configuration > Exim Configuration Editor, Mail Tab: Set SMTP Sender: headers
     
  4. rhm.geerts

    rhm.geerts Active Member

    Joined:
    Jul 29, 2008
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Maastricht
    cPanel Access Level:
    Root Administrator
    Thank you, but normally if I use the -f flag for example in my forum configuration of vBulletin, also the return-path will be set to my domain name instead of the nobody@hostname. This is not the case here unfortunately. But that was the reason that I enabled it.

    I removed the -f setting for now.

    If anybody has a solution for the return-path problem this would be very welcome.:)
     
Loading...

Share This Page