Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to force cpanel.* and whm.* to use SSL ?

Discussion in 'General Discussion' started by wonker, Apr 3, 2009.

  1. wonker

    wonker Active Member

    Dec 5, 2007
    Likes Received:
    Trophy Points:

    I'm asking for some help here as I've contacted cPanel and they say that this is normal and nothing can be done.

    I run cPanel on Centos with the latest release version, and I'm almost sure that the subdomains webmail.*, cpanel.*, whm.* used to redirect to the correct ports (https://hostname:2096, https://hostname:2083 and https://hostname:2087).

    However now instead of doing this they go via the proxy, and if I deactivate the proxy in WHM it shows the default Apache "Great Success" Page.

    As you all know, it's a security risk to allow users to connect to cPanel with plain text passwords and therefore it's important to only allow users to connect with https.

    /webmail, /cpanel and /whm all redirect correctly to their ssl ports but not the subdomains.

    I have given all my customers webmail.theirdomain.ext for the webmail as it used to redirect fine.

    Is there a way to force to https when using cpanel.* and whm.* ? and if not is there a way to get webmail.*, cpanel.* and whm.* to redirect to the same URLs as /cpanel, /webmail and /whm ?
    #1 wonker, Apr 3, 2009
    Last edited: Apr 3, 2009
  2. servertechs

    servertechs Active Member

    Aug 24, 2008
    Likes Received:
    Trophy Points:
    You can find the solution in

    Tweak Settings>>Server Setup

Share This Page