The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how to forward cpanel default email?

Discussion in 'E-mail Discussions' started by sohlinux, Apr 10, 2012.

  1. sohlinux

    sohlinux Active Member

    Joined:
    Sep 26, 2008
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    how can I forward cpanel default email address user@server.domain.com to another email address?

    there doesnt appear to be an option to do it in cpanel but I do have ssh root access

    thanks
     
    #1 sohlinux, Apr 10, 2012
    Last edited: Apr 10, 2012
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,450
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You can via the 'Default Address' in your cPanel but why would you want to do that?
     
  3. sohlinux

    sohlinux Active Member

    Joined:
    Sep 26, 2008
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    there is not an option, my cpanel default email is user@server.domain.com not user@domain.com

    and I want to do it because I dont want to login to 2 different email accounts, I would rather just have one

    is there a way of just redirecting the email because I dont want to keep a copy on the server

    just redirect cpanel default email address user@server.domain.com to another email address?

    thanks
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,450
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You shouldn't be getting any email at user@server.domain.com under normal circumstances.

    In your cPanel > Preferences section, Update Contact Info, you add an off server email address. Valid email to user@server.domain.com should be sent to that off server email.

    In the Default Address area I mentioned you set all unrouted email to be discarded.

     
  5. sohlinux

    sohlinux Active Member

    Joined:
    Sep 26, 2008
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    that doesnt work, in cPanel > Preferences section I have already added my Contact Info with an off server email address , I see no option to forward or relay the email anywhere in cpanel or whm

    the default email is user@server.domain.com so how can I change it to user@domain.com and either forward or relay the email?

    thanks
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,450
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Do you have root access to this server? If yes, the Feature List Manager has this item that can be enabled:
    Default Address Manager

    Enabling that gives you whats been mentioned above.
     
  7. sohlinux

    sohlinux Active Member

    Joined:
    Sep 26, 2008
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Yes I have root access to whm or ssh and the default address manager is already enabled

    in cpanel under Set Default Address it gives an option to Send all unrouted email for: domain.com but not user@server.domain.com

    am I missing something?

    thanks
     
  8. sohlinux

    sohlinux Active Member

    Joined:
    Sep 26, 2008
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    if forwarding of the default email user@server.domain.com is not possible with cpanel would it be possible to setup automatic forwarding using the access webmail link and using either @email, horde, roundcube or squirrelmail?

    thanks
     
    #8 sohlinux, Apr 10, 2012
    Last edited: Apr 10, 2012
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,450
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Unrouted mail should be discarded. faked@yourdomain.com, viagra@yourdomain.com as examples.
    cPanel Linux user system emails (user@server.domain.com) are/should be sent (forwarded) to the Contact Email.

    You can check in on that default system email from time to time to check for emails (for example if you have a mail script on your account that's not working properly, mail might go here to die) but under normal conditions there shouldn't be any reason mail goes there.

    If mail is going there to the system users account (which is not a real email address), might you explain here a bit more about those emails? That might be useful in figuring out how to prevent this from happening.

    For example, if your cPanel username is johnny, your server hostname is server.domain.com and you sent an email right now to johnny@server.domain.com that email should be bounced back to you within seconds. It should not be accepted. You want that.

    If you forwarded all system emails, no email scanning, IIRC, takes place. That means that every faked@yourdomain.com, viagra@yourdomain.com email is coming to you. You do not want that. And worse, if you're forwarding all that email to an outside email account, like yahoo, or hotmail or even google, these companies might think you're sending spam from your server and blacklist your IP.

    You should certainly never want that to happen on a shared IP environment or you might get lots of complaints when other accounts emails are bouncing due to the IP it came from being blacklisted.

    I am no email expert. I do what works. If this post is not helpful enough I'll have to defer further assistance to you by someone else reading this thread with more experience and details to help you achieve what you want here.

    HTH!
     
  10. sohlinux

    sohlinux Active Member

    Joined:
    Sep 26, 2008
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    thanks for the info :)

    I am using an oscommerce website and when I send out a mailing list all the bounced email goes back to user@server.domain.com but oscommerce is configured with an email address off the server.

    I simply want to forward all email to another email address off the server, it works fine with user@domain but appears impossible to forward email from user@server.domain.com

    someone suggested on another thread to make a .forward file with the forwarding email address inside and put it inside the /home/user directory but it doesnt work.

    I guess I will just have to keep logging into the user account in via the cpanel webmail link to check for the bounced emails unless someone come up with a fix.
     
    #10 sohlinux, Apr 10, 2012
    Last edited: Apr 10, 2012
  11. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The .forward file is what you want to use.

    But a better solution would be to configure your script to use an envelope-sender email address that you wan these bounce messages to go back to.

    It sounds like your script is not setting an envelope-sender, so it's defaulting to just your cPanel account's username, which won't get picked up by the /etc/valiases/domain.com default address. The .forward file will, but it's not an ideal solution.
     
  12. sohlinux

    sohlinux Active Member

    Joined:
    Sep 26, 2008
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1

    I finally got it to work using the .forward file, it appears that I had some incorrect user permissions the first time I tried it, now its just fine after a little chown, it will suffice until I figure out why oscommerce is using the default email rather than my actual email address.

    :)
     
Loading...

Share This Page