Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to get cPanel to add SSL to domain again?

Discussion in 'Security' started by SCott Galambos, Aug 29, 2017.

Tags:
  1. SCott Galambos

    Joined:
    Jul 13, 2016
    Messages:
    22
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    I added an add-on domain. It tried to add the WHM built-in SNI SSL cert which is good. But the DNS resolved to the wrong IP by chance so the web site always comes up with an SSL cert invalid error. How do I fix this? I went into WHM -> Manage SSL Hosts and deleted the SSL cert for the domain. HOw do I tell cPanel to readd it now that I have the DNS resolving properly for the new add-on domain? Its not coming up in the Pending Queue for Manage AutoSSL.
     
  2. martin MHC

    martin MHC Active Member

    Joined:
    Sep 14, 2016
    Messages:
    38
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    From the WHM main menu:
    Go to Manage AutoSSL ==> Manage Users ==> Select the user you want to add ==> Check the tickbox ==> Click the button saying "Enable AutoSSL on 1 User" . Then check the logs tab to see that it worked.
     
  3. SCott Galambos

    Joined:
    Jul 13, 2016
    Messages:
    22
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    Thanks, but the user already has AutoSSL enabled. And it is working. What I am trying to do is move one domain & site. But I am trying to move the site first to make sure it works and leave the DNS for the domain pointing to the old site until its confirmed working. So I update my local hosts file to point to the cPanel server to make sure the moved site works. This is fine, except for SSL because AutoSSL (on the cPanel server) I guess is trying to verify & install the cert for the domain but the domain is resolving to the old IP still as expected. It doesn't like this so it fails. "The domain whatever.com resolved to an IP address "y.y.y.y" that does not exist on this server." Because only my local hosts file points to the new IP of x.x.x.x, not the global DNS yet.

    Any way around this? I guess the AutoSSL failure is because an external server is generating the certs (and looking up the IP) and giving the cert to my cPanel server. Because I also forced the x.x.x.x domain in /etc/hosts in the cpanel server but that doesn't cut it either.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,371
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The domain validation process for the certificate will fail if the domain name is not resolvable to an IP address associated with the cPanel server it exists on. You will need to wait until the domain name resolves to the cPanel server before the certificate installation will succeed.

    Thank you.
     
Loading...

Share This Page