Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

How to get the correct file and not /opt/cpanel/ea-php56/root/usr/bin/php-cgi

Discussion in 'EasyApache' started by tejli, Nov 4, 2016.

Tags:
  1. tejli

    tejli Member

    Joined:
    Aug 8, 2016
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    vienna
    cPanel Access Level:
    Website Owner
    Hello.

    I moved my server to a new one and now am getting many of those when I click the Precess Manager:

    /opt/cpanel/ea-php56/root/usr/bin/php-cgi

    In the old server I was getting the right file path.

    Any idea how to fix this?
     
  2. JacobPerkins

    JacobPerkins Well-Known Member

    Joined:
    May 2, 2014
    Messages:
    619
    Likes Received:
    96
    Trophy Points:
    103
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    Your new server appears to be running EA4. That php-cgi binary is the SCL version of php56, so you can run multiple versions of PHP on the same system. This is normal :)

    Are you experiencing any issues?
     
  3. tejli

    tejli Member

    Joined:
    Aug 8, 2016
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    vienna
    cPanel Access Level:
    Website Owner
    Hi Jacob. Yes I do face issues because I dont know what file is causing the load so I can fix it.
    In the old server in most times was showing php files that was making problems and after renaming them the load was normal again but now I see the same message for all. So there is no way to fix it?
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    The functionality you are referring to is enabled by default when using suPHP with the "full_php_process_display" option:

    full_php_process_display When you set this value to true, the mod_suphp module executes PHP scripts in a way that displays both the PHP interpreter and the script's file name in the process list. To hide the script's file name and improve security, set this value to false.

    This is documented at:

    PHP Handlers - EasyApache 4 - cPanel Documentation

    Could you verify if you are using the same PHP handler as the previous server (e.g. suPHP)?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. tejli

    tejli Member

    Joined:
    Aug 8, 2016
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    vienna
    cPanel Access Level:
    Website Owner

    Sorry to bump it.

    Where can I find and change that full_php_process_display? AM on Cloudlinux 7.x

    Thank you
     
    #5 tejli, Apr 19, 2017
    Last edited by a moderator: Apr 19, 2017
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    suPHP configuration settings are stored in the following file as of EasyApache 4:

    /etc/suphp.conf

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. tejli

    tejli Member

    Joined:
    Aug 8, 2016
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    vienna
    cPanel Access Level:
    Website Owner
    Thank you.
    It was True and changed to False but still am getting such filenames: /opt/cpanel/ea-php56/root/usr/bin/php-cgi
     
  8. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    You'd still see "/opt/cpanel/ea-php56/root/usr/bin/php-cgi" as the process name. It's the path to the PHP file that's hidden. Can you confirm the path to the PHP file itself still appears in the process list after restarting Apache?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. tejli

    tejli Member

    Joined:
    Aug 8, 2016
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    vienna
    cPanel Access Level:
    Website Owner
    Yes as I have said before still appairs like this: /opt/cpanel/ea-php56/root/usr/bin/php-cgi.
    Id like to see the real file here like it was in the old serever ex: username/public_html/file.php
     
  10. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    It's only possible when using suPHP as the PHP handler, and when full_php_process_display is set to "True" in the /etc/suphp.conf file. Are you sure suPHP is configured as the PHP handler for PHP version 5.6 on your system? PHP handlers are configured under the "PHP Handlers" tab in "WHM >> MultiPHP Manager".

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice