The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to increase the "number of files returned" limit

Discussion in 'General Discussion' started by matti0000, Dec 10, 2006.

  1. matti0000

    matti0000 Member

    Joined:
    Dec 10, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Gidday

    One of my site's folders contains 2000+ files but my FTP clients can only show 1998. How do I fix this?
     
  2. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    if your using pure-ftpd, in the configuration file you'll see a setting like this:
    Code:
    # 'ls' recursion limits. The first argument is the maximum number of
    # files to be displayed. The second one is the max subdirectories depth
    
    LimitRecursion              2000 8
    
    you can make the necessary adjustment and restart pure-ftpd and this help.

    Mickalo
     
  3. matti0000

    matti0000 Member

    Joined:
    Dec 10, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Where do I find this config file?
     
  4. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    should be in the /etc folder.

    Mickalo
     
  5. matti0000

    matti0000 Member

    Joined:
    Dec 10, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Nope. :(

    There are these:
    .imapv4cp5c
    ftpquota

    and in thecia.com.au there are:
    passwd
    passwd,v
    quota
    quota,v
    shadow
    shadow,v
     
  6. rhysmcmurdo

    rhysmcmurdo Member

    Joined:
    Apr 12, 2006
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    This needs to be done in the /etc/pure-ftpd.conf file. From the looks of it, you do not have admin/root privileges on this server? If this is the case, you will need to ask the system admin (nicely) to modify this for you.
     
  7. matti0000

    matti0000 Member

    Joined:
    Dec 10, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Can't I just upload a file named pure-ftpd.conf?
     
  8. Manuel_accu

    Manuel_accu Well-Known Member

    Joined:
    Jun 19, 2005
    Messages:
    191
    Likes Received:
    0
    Trophy Points:
    16
    Hey,

    Are you sure, you are running pure-ftpd? you may using other ftp server. first check this and based on it check configuration.

    Thanks,
     
  9. matti0000

    matti0000 Member

    Joined:
    Dec 10, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    WHM\Tweak Ftp Settings

    Installed Ftp Server
    pure-ftpd
    Button: Switch to Proftpd

    Anonymous Ftp
    Anonymous Ftp is currently: disabled
    Button: Enable Anonymous Ftp

    Does this mean yes?
     
Loading...

Share This Page