Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED How to increase the Solr memory limit

Discussion in 'E-mail Discussion' started by Syneic, Apr 5, 2019.

Tags:
  1. Syneic

    Syneic Member

    Joined:
    Mar 17, 2014
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    DataCenter Provider
    Hi,

    We have several accounts which is 15+GB with several hundred thousand emails total.
    And we can see index-worker running and solr process building in ram usage untill it reaches 512MB rss.

    And after this happens searching in those inboxes takes upwards to 30minutes.

    Do cPanel provide any way to adjust this through whm gui/api or do i need to change the config files ?
     
    Jean Boudreau likes this.
  2. Jean Boudreau

    Jean Boudreau Member

    Joined:
    Mar 31, 2017
    Messages:
    19
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Caraquet, NB, Canada
    cPanel Access Level:
    Root Administrator
    We also disabled Solr last year as we have many accounts with over 10GB of emails and they say the search was not working once we activated the Solr plugin.
     
  3. Syneic

    Syneic Member

    Joined:
    Mar 17, 2014
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    DataCenter Provider
    I've had it disabled up until recently, but due to some email client software not building proper index files, they makes the server read all files in inbox while searching creating huge IO load on the server.
    Using solr has mitigated this, but now some have to much mail for solr in current configuration.
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,529
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @Syneic,

    The default memory limit for Solr is defined in /etc/sysconfig/cpanel-dovecot-solr:

    Code:
    SOLR_MEMORY="512m"
    Can you try increasing this value from 512m to 750m to see if that helps? Remember to restart the service after making the change:

    Code:
    /usr/local/cpanel/scripts/restartsrv_cpanel_dovecot_solr
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    Jean Boudreau likes this.
  5. Syneic

    Syneic Member

    Joined:
    Mar 17, 2014
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    DataCenter Provider
    Exactly what i was looking for, thank you.
     
    cPanelMichael likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice