The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to install GD 2.0.29 or higher?

Discussion in 'General Discussion' started by amilo, Jun 25, 2005.

  1. amilo

    amilo Registered

    Joined:
    Sep 7, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello

    Can anyone help me installing:

    GD Version bundled (2.0.29 or higher)

    2.0.28 is not supporting animated GIFs (WHM installs 2.0.28)

    WHM installed 2.0.28, not higher :confused:

    Thanks
    Amilo
     
  2. Ali Hamad

    Ali Hamad Member

    Joined:
    May 22, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Hello amilo :

    the last stable versin is 2.0.33 . you can upgrade GD by:
    cd /usr/local/src
    wget http://www.boutell.com/gd/http/gd-2.0.33.tar.gz
    tar -czvf gd-2.0.33.tar.gz
    cd gd-2.0.33
    ./configure --prefix=/usr
    ##BY DEFAULT, THE LIBRARY IS INSTALLED IN /usr/local/lib and the include files are ##installed in /usr/local/include , but as you said , you want to upgrade to higher version , ##so use ./configure --prefix=/usr .

    make
    make install

    for furhter information :
    http://www.boutell.com/gd/manual2.0.33.html

    regard ,
     
  3. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    I think you actually meant to say ...

    tar -zxvf gd-2.0.33.tar.gz

    I got a pot of hot coffee sitting here if you want some :)
     
    #3 Spiral, Jun 25, 2005
    Last edited: Jun 25, 2005
  4. Ali Hamad

    Ali Hamad Member

    Joined:
    May 22, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1

    you are right . thank you , it was typo haha , it was too late here :p

    Thank you again ,

    Ali Hamad
     
  5. amilo

    amilo Registered

    Joined:
    Sep 7, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    gd installed?

    Hello guys

    I installed GD like instructed (thanks Ali and Spiral :) ), but when checking server with phpinfo() it still says GD version Bundled(2.0.28 compatible)

    Is this normall? Is there an other way to check if the install was succesfull?

    Thanks
    Amilo
     
  6. amilo

    amilo Registered

    Joined:
    Sep 7, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    GD upgrade additional info

    hello again,

    I also tried to install it with only ./configure, but I still keep having the GD version 2.0.28 when retrieving info with the phpinfo() command.

    Maybe I have now 2 versions running (usr/local/lib and usr/lib), or none, I don't know.
    Any hep would be welcome...

    Greetings
    amilo
     
  7. taotoon

    taotoon Well-Known Member

    Joined:
    Nov 14, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Thank for the info too.


    I see the GD is installed in menu Main >> Software >> Install a RPM
    But I couldn't find GD in unix command. Is these normal ?
    Then I tried to click reinstall.
    It said "gd: installed version 1.8.4-11 is up to date, no action needed."


    Is it safe to manual install v2.x.x ?
     
    #7 taotoon, Jun 28, 2005
    Last edited: Jun 28, 2005
  8. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Unless you really need an up-to-date version of GD, otherwise you don't have to. It should be safe to install GD manually, at the prompt.

    In addition, you need to follow the instructions very carefully and use the full commands as instructed.

    phpinfo() shows the current version installed on your server and that means your installation was successful.
     
  9. bornonline

    bornonline Well-Known Member

    Joined:
    Nov 19, 2004
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Followed these as well and phpinfo still says GD version 2.0.28 compatible for me too. Can anyone confirm that it still says this even after upgraded?
     
  10. taotoon

    taotoon Well-Known Member

    Joined:
    Nov 14, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Note for newbies:

    For my problem, after I read all whole day, I found that I have to recomplie apache with GD enable.



    When see in phpinfo, I have v2.0.28 too.
    I am on release tree version.

    WHM 10.1.0 cPanel 10.2.0-R82
    RedHat 9 i686 - WHM X v3.1.0
     
Loading...

Share This Page