How to install hostname and cPanel WHM service SSL

callumbaillie

Registered
Feb 28, 2011
1
0
51
Hi everyone

I am trying to install an SSL certificate for my hostname and cPanel service ssl.

I have them all installed hostname crt through "SSL/TLS >> Install a SSL Certificate and Setup the Domain"
and the cpanel/whm crt in
"Service Configuration >> Manage Service SSL Certificates"

This is a comodo SSL

They all seem to be installed ok and i've rebooted my cpanel service and my whole server.

However when i goto my hostname (https://) i get the self signed untrusted connection.
And the same when i goto https://my.hostname.com:2087(/whm).

Are there any steps im missging out in installing this?

Thanks in advance
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Could you try restarting cPanel in SSH using the following:

Code:
/etc/init.d/cpanel restart
Also, check back in WHM > Service Configuration > Manage Service SSL Certificates area that the cPanel/WHM/Webmail certificate shows as the one you've installed. It should show the SSL provider and date of issue for the certificate. If it still shows the unsigned one, it didn't get properly installed.
 

dilitalo

Member
Jan 16, 2007
12
0
151
Hi, we purchased a ssl cert with Geotrust (RapidSSL) and created the cert for the hostname of the server. It was installed with success using "Manage Service SSL Certificates".

When we goto domain.com/cpanel, we are getting a "This Connection is Untrusted" even after we installed the cert.

mydomain.com:2096 uses an invalid security certificate.
The certificate is only valid for pub02.mydomain.com
(Error code: ssl_error_bad_cert_domain)

We also tried redirecting to the hostname after SSL install, still no luck actually getting a "Server not found" error?

What could be the problem?

Thanks in advance.
 

dilitalo

Member
Jan 16, 2007
12
0
151
Hi, just realized that we forgot to create A records for the server name in the DNS Zone. Once we did this and redirected to the hostname the cert worked!!