The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to install InnoDB (step by step)

Discussion in 'Database Discussions' started by michelle_ai, Apr 29, 2010.

  1. michelle_ai

    michelle_ai Registered

    Joined:
    Apr 29, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    :eek:

    I nearly crazy about innoDB.
    I read all the post related with innoDB,

    But i still dont know how to install it.

    My host tell me, i can install it by myself.

    Any i didnt see any place in PHPMYADMIN ,where i can enable the innoDB.

    People said, i can use ssh to do it.

    But How?

    I click SSH/Shell Access.

    Which one i should choose, about username and password, is the same with login cpanel?

    But after i enter the SSH, it cant type anything.

    And I also use Putty ,,,,i can connect with my sever.

    But it said ,,permission denied.......

    Plz,,Plz,,,,Help me..

    I need innoDB to install Magento....

    Thanks
     
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Do you own the server OR you have a Shared/Reseller plan somewhere? If you own the complete server, ssh to the server using Putty

    user: root
    pass: root password i.e. the one you use to access WHM

    Once you are logged in, check if Innodb is already there. Execute the command:

    this will tell you if Innodb is present on the server and whether it is ON or OFF. Forward the output of the above command so people here can assist you further.
     
  3. kuldeep_

    kuldeep_ Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    If you see have_innodb is set to OFF. It indicate thet innodb is disabled on your server.

    To enable it, ssh to your server as root and open file /etc/my.cnf with your favorite editor.

    Search for line skip-innodb and comment the line by placing # in the starting of the line.

    Save and quit the file and restart mysql service for changes to take effect.

    HTML:
    /etc/init.d/mysql restart
    
    Now check status of InnoDb engine
    HTML:
    mysqladmin variables | grep have_innodb
    
    Above command should show output as YES now.
     
  4. johnburk

    johnburk Well-Known Member

    Joined:
    Jun 23, 2006
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    What if there is no skip-innodb in the config file?
     
  5. kuldeep_

    kuldeep_ Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    In this case It seems InnoDb is already enable on server.

    SSH server as root, go to mysql prompt and check available database engines.

    Check what do you see corresponding to InnoDB in the Support column.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    652
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  7. Jalal Hoseini

    Jalal Hoseini Member

    Joined:
    Apr 17, 2015
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Armenia
    cPanel Access Level:
    Root Administrator
    Hi,

    I have same problem,
    the ibdata1 had a big volume, and I made a backup from my Databases, and removed ibdata1 file in /var/lib/mysql/ and then restored databases.
    now all is good, but just I do not have the innodb engine working.

    Missing innodb in "mysql> show engines;"
    and also innodb is not skipped in my.cnf
    root@avts1 [~]# cat /etc/my.cnf | grep "skip-innodb"
    root@avts1 [~]#

    looks that I need to reinstall the mysql server or mysql engine innodb on this server.

    I`ll be thanksful if you update me.
    regards
     
  8. 24x7ss

    24x7ss Well-Known Member

    Joined:
    Sep 30, 2014
    Messages:
    271
    Likes Received:
    16
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Yes, in your case you have to reinstall mysql on server or try upgrading mysql this will fix your innodb engine issue. For better performance of site I will suggest you to go with MariaDB instead of mysql.
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    652
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Do you notice any error messages in /var/lib/mysql/$hostname.err when restarting MySQL?

    Thank you.
     
Loading...

Share This Page