Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

How to install php 5.3-dev?

Discussion in 'General Discussion' started by kenashkov, May 27, 2008.

  1. kenashkov

    kenashkov Active Member

    Joined:
    Nov 23, 2006
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Sofia, Bulgaria
    cPanel Access Level:
    Root Administrator
    Hello,

    I need to use 5.3 branch on a host and I prefer to use WHM/easyapache to do the installation. Up to the moment I used this server with Apache 2.2, suexec and both php 4.4 and php 5.2 running as CGI. I dont need anymore php 4.4 so this is not an issue.
    At the moment using the phpinfo() I got the ./configure line and used it to compile php 5.3-dev (from command line without using easyapache). I works but only as dso module. If I try to change it to cgi from "Configure PHP and SuExec" it is loading the previous version of php 5.2 (from /usr/local/cpanel/cgi-sys/).
    So my question is - is there easy way to compile an unsupported version of php and use it with apache/suexec/cgi (using easyapache or manually)?

    P.S. Actually I triend to fool easyapache and during the compilation I just replaced the files in php-5.2.4 source dir with these from php 5.3-dev. The compilation was OK but afterwards the CGI didn't work at all.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice