mdfdcntnt

Registered
Feb 7, 2020
1
0
1
London, UK
cPanel Access Level
Root Administrator
For the last month I have been struggling to install a Ruby app - OpenProject - on a CentOS 7 with cPanel/WHM VPS. The app is apparently installed, according to SSH tests, but "deploying" the app to the browser is the problem. I know in general terms that I need Phusion Passenger and then use Application Manager in cPanel, but many parts are still missing.

I had all (?) the essential Ruby via Passenger modules provisioned in my active EasyApache4 package, but using SSH tests and looking for ruby folders, it didn't look like anything was actually installed.

Running the following in SSH did install loads of stuff:

yum -y install ea-ruby24-mod_passenger ea-ruby24-ruby-devel ImageMagick-devel sqlite-devel ea-apache24-mod_env ea-ruby24-rubygem-passenger ea-ruby24-rubygem-rack ea-ruby24-rubygem-rake ea-ruby24-rubygem-sqlite3

Or will that conflict with the EasyApache4/cPanel/WHM way? When I check with 'ruby --version', I get '-bash: ruby: command not found'. Ruby is still not installed?

How can I install Ruby on CentOS 7/cPanel/WHM and check if Ruby actually works? What is the correct 2020 cPanel/WHM/EasyApache4 way?

Edit:

Next I have tried to install Ruby again, using:

sudo yum install ruby

Again loads of stuff is apparently installed. Now when I check with 'ruby --version', I get 'ruby 2.0.0p648 (2015-12-16) [x86_64-linux]'.

That looks better, but will it conflict with EasyApache4 or what I tried to do before?
 
Last edited:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston