how to kill backup process? - new backup system in 11.38 kills my server

Foxhound

Member
Sep 17, 2013
13
0
1
cPanel Access Level
Root Administrator
Hi,

Long time reader but now I could use some help. I am not a very experienced server administrator so excuse any stupid questions.

I am trying to run this new backup system which came with one of the newer WHM versions. I disabled the legacy backup (also all users) but everytime I try to run it it brings my server to its knees. Last night it completely crashed my server and it was down for the entire night.
So, this morning I tried it manually so I could see whats happening but it is not looking good.
The serverload is like 30 - 50 and I only have 8 cpu's so its going down if this takes to long.

I would like to kill the backup process but I do not know how to do it. So if anyone can give me some assistance I would appreciate this.

The server has one large account (users) and a few small ones. Right now I set the backup to run on all users. To prevent the backup from crashing my server should I maybe run the backup manually on each user seperate first?


When we used the legacy backup this never happened so I am kind of at a loss.
 

Foxhound

Member
Sep 17, 2013
13
0
1
cPanel Access Level
Root Administrator
Hmm, whats even more weird is that in the backup config I set it to use uncompressed, yet it is compressing everything.
I really wonder what is going on. If this new backup system is just one bugged thing I would expect the support for legacy to not end, but which I read will.

I rather have a legacy backup which I cant use than daily backups while the server is down all day like now just to make the backup.

Is there anyone who has an idea whats going on? Right now the server is trying to kill itself with a load of nearly 100. And I still dont know how to kill this process.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

You may want to consider utilizing the following option under "Stats and Logs" in "WHM Home » Server Configuration » Tweak Settings":

"Extra CPUs for server load"

Per it's description:

The load average above the number of CPUs at which cpuwatch, cpanellogd, backups, and CPU stats consider the system to be in a critical load state. For example, a server with 4 physical CPUs and a value of 2 in this field will be considered “critical” in these cases once the load reaches 6.

This will ensure the backup process pauses when the load reaches a certain threshold. Also, if you want to kill a backup process, find the process ID with a command such as:

Code:
ps auxf
Then, kill the process:

Code:
kill -9 PID
Thank you.
 

Foxhound

Member
Sep 17, 2013
13
0
1
cPanel Access Level
Root Administrator
Thank you, that was very usefull :)

Do you maybe have any idea why my backup is cmpressing the users accounts to .tar? I double tripple checked and the backup is set to not compress. I started this backup with "/usr/local/cpanel/bin/backup".
Could this cause it is ignoring my backup config settings?
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
77
308
cPanel Access Level
Root Administrator
Thank you, that was very usefull :)

Do you maybe have any idea why my backup is cmpressing the users accounts to .tar? I double tripple checked and the backup is set to not compress. I started this backup with "/usr/local/cpanel/bin/backup".
Could this cause it is ignoring my backup config settings?
.tar is not compression. It's an archive. It's as if you appended all files into one giant file. For compression gzip is used, which will leave your file with a .gz extensions.
 
  • Like
Reactions: ebuka

Foxhound

Member
Sep 17, 2013
13
0
1
cPanel Access Level
Root Administrator
Ah ok thank you very much. That makes sense now.
I have set backup to incremental now, together with the "Extra CPUs for server load" tweak setting pretty much fixed these issues and my server is running again.
I can still see what happened this morning has its influences but its up.

Thank you for all your assistance! It was very much appreciated :)