The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to make EasyApache use an older Apache 2.2 release?

Discussion in 'EasyApache' started by Vince, Aug 23, 2010.

  1. Vince

    Vince Active Member
    PartnerNOC

    Joined:
    Aug 13, 2001
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Hey,

    I'm bumping in to some problems with Apache 2.2.16 that were not present with Apache 2.2.15 or earlier.

    How can I make EasyApache use an older version of Apache 2.2 during the build process?

    Thanks,
    Vince.
     
  2. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    The only supported versions of Apache are those that are included in EasyApache; unless an EasyApache build archive was saved of the prior Apache version it is not something easily reverted.

    EasyApache build archives, that is, backups of an Apache installation, may be stored in the following paths:
    Code:
    /usr/local/apache.backup/
    /usr/local/apache.backup_archive/
    If you have an EasyApache build archive of the desired Apache version then it may be manually restored using the following:
    Code:
    # /scripts/easyapache --restore-archive
    Bring up UI to choose available archives and restore them if desired
    
    # /scripts/easyapache --restore-archive=listonly
    List available archives only
    
    # /scripts/easyapache --restore-archive=/path/to/easyapache/archive
    Attempt to restore this build archive
    !! only use if you are 100% sure the path is an easyapache build archive !!
    Related reference:
    Code:
    # /scripts/easyapache --help
     
Loading...

Share This Page