How to map webmail.domain.com to webmail without any port?

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
Hi,

Is there any way to access webmail on the default port, i.e., 80.
Currently,

https://www.domain.com:2096/ OR http://www.domain.com:2093/

instead, how to map http://webmail.domain.com/ to the above.

Thank you
Prasad
In tweak settings, make sure the following settings are enabled:

Add proxy VirtualHost to httpd.conf to automatically redirect unconfigured cpanel, webmail, webdisk and whm subdomains to the correct port (requires mod_rewrite and mod_proxy)
Automatically create cpanel, webmail, webdisk and whm proxy subdomain DNS entries for new accounts. When this is initially enabled it will add appropriate proxy subdomain DNS entries to all existing accounts. (Use /scripts/proxydomains to reconfigure the DNS entries manually)
Also, make sure you have mod_proxy installed. You can verify this via EasyApache. Go to WHM -> Software -> EasyApache and proceed based on your current configuration to step 5. Then click on "Exhaustive Options List" and ensure "Proxy" under Apache is selected. If not, check the checkbox and proceed with the build process. Otherwise, you can just exit EasyApache since mod_proxy is already installed.

For existing accounts, if all of this does not automatically enable this functionality, use /scripts/proxydomains to set up the DNS accordingly.
 

capoinfra

Well-Known Member
Oct 25, 2007
119
1
66
Uruguay
Hello,

I already have all the requeriments ready but is not working and always redirect me to the port. The only thing I not try yet is /scripts/proxydomains. Is safe run this script? Is not going to cause problems with the domains?
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
It will not cause issues with the domains to run /scripts/proxydomains as it simply sets up proxy domain entries for whm, cpanel, webmail and webdisk
 

capoinfra

Well-Known Member
Oct 25, 2007
119
1
66
Uruguay
Thank you.

But does not works.

Still redirects to http://www.domain.com:2095/

Add proxy VirtualHost to httpd.conf to automatically redirect unconfigured cpanel, webmail, webdisk and whm subdomains to the correct port (requires mod_rewrite and mod_proxy)
Automatically create cpanel, webmail, webdisk and whm proxy subdomain DNS entries for new accounts. When this is initially enabled it will add appropriate proxy subdomain DNS entries to all existing accounts. (Use /scripts/proxydomains to reconfigure the DNS entries manually)
These options are enabled in WHM, proxy and rewrite enabled too, but does not works.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Then opening up a ticket is likely warranted if you'd also ran that script and it isn't working.
 

nightfall_sg

Active Member
Apr 15, 2004
39
0
156
cPanel Access Level
Root Administrator
Hi. I have the same problem too.

I have ran the script , got apache sorted out etc.. but using the webmail.domain.com still gets redirected to port 2096.

What can be done?