The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to point website somewhere else, but keep email on my server?

Discussion in 'Bind / DNS / Nameserver Issues' started by PumpinIron, May 13, 2015.

  1. PumpinIron

    PumpinIron Member

    Joined:
    Mar 8, 2013
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Okay, this should be seemingly simple, but somehow it's confusing me. I have a domain I purchased through GoDaddy. I pointed the name servers to my server that I have with HostGator. That works fine and dandy, no issues whatsoever.

    However, we recently decided to move the website to SquareSpace, but keep the email on the existing server. So, I went into the Advanced DNS editor in cPanel (on the current server) where I then added the new A records and CNAME records that the SquareSpace documentation told me to add.

    Website works great, when you go to the website in a web browser it points you to the new SquareSpace website. However, emails are no longer working, which I don't understand.

    Here's my current DNS records:
     

    Attached Files:

    #1 PumpinIron, May 13, 2015
    Last edited by a moderator: May 14, 2015
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    You should verify the domain name uses the correct MX records and mail "A" record via a website such as IntoDNS (or the dig command). Also, ensure you select "Local Mail Exchanger" if email is handled on the same server as your DNS.

    Thank you.
     
  3. PumpinIron

    PumpinIron Member

    Joined:
    Mar 8, 2013
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Mail is set to local, still no luck with mail.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. PumpinIron

    PumpinIron Member

    Joined:
    Mar 8, 2013
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I am using a local client (Mac Mail) to connect. The odd thing is using Mac Mail I can RECEIVE emails, but not send them.

    On the other hand, when I go to the website's cPanel and access webmail, I can both send and receive just fine.

    I've triple checked my email settings in Mac Mail and I'm sure they're right. Correct ports for SMTP, correct server name, etc.

    For some reason I think this has to do with DNS because none of this happened until I pointed those DNS records to the SquareSpace site.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Are you sure the mail server name used for outgoing email is accurate? It's possible the mail server name is configured as the actual domain name instead of "mail.domain.com" or the mail server's hostname.

    Thank you.
     
  7. PumpinIron

    PumpinIron Member

    Joined:
    Mar 8, 2013
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    The mail server for both incoming and outgoing mail is setup as mail.calcean.com. According to my mail configuration settings in cPanel that is what is should be.

    I did however try using calcean.com instead of mail.calcean.com for incoming SMTP server and still it won't connect. As a precaution I added my IP to the cPhulk white list just to make sure I wasn't being blocked somehow for failed login attempts. That does nothing either...

    Everything is standard in my SMTP settings, I'm trying to connect to port 25 at mail.calcean.com (and calcean.com) using my email address as the username and the correct password.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature so we can attempt to reproduce the issue. There's likely a slight misconfiguration in your email client or with your DNS settings. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  9. Zero.80

    Zero.80 Member

    Joined:
    May 6, 2015
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mexico
    cPanel Access Level:
    Root Administrator
    delete all mx records.... add a new one with priority 1 and mail.domain.com, check http://mxtoolbox.com/ to make sure your mail.domain.com is resolving to the correct IP address...
     
  10. wintech2003

    wintech2003 Member
    PartnerNOC

    Joined:
    Sep 15, 2010
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Greece
    cPanel Access Level:
    DataCenter Provider
    By default cPanel uses domain.com as your MX record, and since you probably changed the IP for domain.com, this means that mail is routed elsewhere.

    Simply create a new A record mail.domain.com and point to your Hostgator VPS's IP, then go to MX entry and set your MX record to mail.domain.com
    (it's possible that you already have a mail.domain.com CNAME - delete that and only keep the A record)
     
Loading...

Share This Page