The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how to prevent changes at /etc/localdomains during DNS editing at WHM. Cpanel 11

Discussion in 'Bind / DNS / Nameserver Issues' started by Nick, May 31, 2007.

  1. Nick

    Nick Member

    Joined:
    Dec 27, 2001
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Hello Guys,

    We are using the dedicated mail server which forwards emails to the cpanel server
    so MX entries of all our domains are not pointed to the cpanel server.
    I have upgraded to Cpanle 11 and have probles with DNS editing now
    each time when I edit the DNS zone at whm (any changes for exmapl just add SPF) it removes the domain from /etc/localdomains and add it to /etc/remotedomains
    It shows the message
    Reconfiguring Local Mail: This server will NOT serve as a mail exchanger for <domainname>

    Please help me to disable this feature because I tired to edit localdomains each time
     
  2. Rodney-E2

    Rodney-E2 Member
    PartnerNOC

    Joined:
    Jun 25, 2005
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Houston, TX
    Same here, we have a spamAppliance and it is doing the same when we make any DNS change, it simply removes it from localdomains and adds to remotedomains.

    Is there some feature to disable this?

    This is a great feature for people switching to a exchange box or gmail or such, but this looks like it will be very very problematic for our application.
     
  3. sloop

    sloop Well-Known Member
    PartnerNOC

    Joined:
    May 4, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    north carolina
    bump.. We are also having the same problem with Cpanel11. The customer users separate servers for just doing spam filtering, but the cpanel server is the final delivery mail server.

    Any ideas?
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Make certain you tick this box in the DNS Zone Editor before szving your changes:

    "Always accept mail locally even if the primary mx does not point to this server"

    That is available in Current, I don't know if it's in Release yet.
     
  5. sloop

    sloop Well-Known Member
    PartnerNOC

    Joined:
    May 4, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    north carolina
    Thanks for your response. I'm running the latest RELEASE, its not in there. I will look forward to the next RELEASE and hopefully it will be there.
     
  6. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    The domain has to be owned by a user for the box to appear. If the box is part of a dns cluster, you will have to check it on the server the user is on.
     
  7. sloop

    sloop Well-Known Member
    PartnerNOC

    Joined:
    May 4, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    north carolina
    Ok that makes sense. But if the domain is not owned by a user, why would it try to disable local mail delivery for that domain? It seems like it should check to see if the domain is hosted locally before trying to disable email delivery.
     
  8. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    If the domain resolves to any ip on the server it will be added to localdomains, if not it will be added to remotedomains.
     
  9. Rodney-E2

    Rodney-E2 Member
    PartnerNOC

    Joined:
    Jun 25, 2005
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Houston, TX
    Do you guys plan on making a option so that it will never goto the remotedomains file in case we are using a spam filtering appliance or such that will then relay mail to the server?
     
  10. Nick

    Nick Member

    Joined:
    Dec 27, 2001
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Could you add this box to the WHM editor or add some optiont to the Tweak Settings?
    my support is tired to remove domains from /etc/remotedomains each time
     
  11. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Tweak setting added in 13914+
     
  12. sloop

    sloop Well-Known Member
    PartnerNOC

    Joined:
    May 4, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    north carolina
    Thanks Nick!!
     
  13. scottc

    scottc Well-Known Member

    Joined:
    Apr 21, 2002
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    This doesn't seem to be true, regardless of whether "Automatically setup /etc/localdomains, /etc/remotedomains, /etc/secondarymx based on where the mx entry is pointed." is checked in Tweak Settings or not.

    If we edit the DNS on domain for which no changes have been made since CP 11, the "Always accept mail locally even if the primary mx does not point to this server. " box is always unchecked. So ANY change made to the DNS settings halts local mail delivery unless the person doing the editing happens to notice the incorrect status of the checkbox. This also happens by simply opening the Edit DNS page and then clicking save without making any changes.

    If we edit the DNS on domain that has been edited after CP 11 installation it will correctly report the status in the "Always accept mail locally even if the primary mx does not point to this server." checkbox.

    Those behaviors do not change after changing the Tweak Settings checkbox.

    We are using 11.4.18-C14158.

    Scott
     
  14. ianmarie

    ianmarie Well-Known Member

    Joined:
    Mar 27, 2006
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Same Here

    My guess is that maybe if you use the default whm dns behaviour of making the primary mail server the same as the domain name
    eg domain. mx 0 domain.
    instead of what many people use
    eg domain. mx 0 mail
    then possibly the problem will go away (untested yet)

    Not sure that the info in an earlier post is true; ie "that as long as your lowest numbered mx is pointing to an ip on that server" (or something like that); as this is the case on mine, but definitely moved the domain from locadomains to remotedomains when I did one edit of the customer's dns.
     
  15. ianmarie

    ianmarie Well-Known Member

    Joined:
    Mar 27, 2006
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    this statement does not prove as correct on my cpanel server

    so dns says

    domain. MX 0 mail
    mail A serverip

    serverip is an aliasip on the server

    took the domain out of localdomains and put it in remotedomains when dns was updated with an unrelated new entry
     
  16. jfgarcia

    jfgarcia Registered

    Joined:
    Aug 27, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Well, In my case, putting:
    domain. mx 0 mail.

    solves the problem. After save the data I get "This server will serve as the primary mail exchanger" and is listed in localdomains.

    Thank you very much for the tip.
     
Loading...

Share This Page