how to properly enable fcgi?

zeki

Member
Jun 19, 2007
12
0
51
So it seems fcgi needs a lot of modifications to get it working.
In my apache error_logs I get a bunch of permission denied

mod_fcgid: stderr: PHP Warning: file_put_contents(/home/user/public_html/config/xml/must_have_modules_list.xml): failed to open stream: Permission denied
mod_fcgid: stderr: PHP Fatal error: Uncaught --> Smarty: unable to write file /home/user/public_html/cache/smarty/compile/ad/9c/bb/wrt54e49b8ca76344_14554329 <-- , referer: https:// user.com/clothing/106-chevron-and-stripe-print-longline-cardigan.html
[Wed Feb 18 06:02:52 2015] [warn] [client 199.27.128.151] mod_fcgid: stderr: thrown in /home/user/public_html/tools/smarty/sysplugins/smarty_internal_write_file.php on line 46, referer: https:// user.com/clothing/106-chevron-and-stripe-print-longline-cardigan.html

i've tried changing user to nobody, tried changing permission 644 and 755, disabled openbased_dir, disabled suexec, disabled selinux, ran cagefsctl --force-update
still getting error.
what else do i need to modify?
 
Last edited:

zeki

Member
Jun 19, 2007
12
0
51
Oh i tried again tonight. i enabled fcsuexec then ran cagefsctl --force-update and i don't get the write permissions anymore.
i think solved for now
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,225
463
Hello :)

I am happy to see you were able to resolve the issue. Thank you for updating us with the outcome.