The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to raise MaxClient Apache 2.2.16

Discussion in 'Workarounds and Optimization' started by Tonic-_-, Oct 29, 2010.

  1. Tonic-_-

    Tonic-_- Member

    Joined:
    Oct 16, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I've been doing a lot of googling with cPanel and apache 2.2.16 and from what I read 2.0 was hard enough to edit the amount for Max Clients over 256.. Everything i've read didn't work..

    Does anyone know how to raise SERVER_LIMIT on Apache 2.2.16 with cPanel. I installed apache 1.3 and have the maxclients set to 1000 and its running awesome but the sad thing 1.3 is outdated and doesn't support the MPM modules that I liked keeping my site running fast till there was no more idle workers.
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Place the limits in /usr/local/apache/conf/includes/pre_main_global.conf file for ServerLimit and MaxClients instead, then run the following commands:

    Code:
    cp /usr/local/apache/conf/httpd.conf /usr/local/apache/conf/httpd.conf.bak101029
    /usr/local/cpanel/bin/apache_conf_distiller --update
    /scripts/rebuildhttpdconf
    /etc/init.d/httpd restart
    This will backup your current httpd.conf, run the distiller to distill the changes in the include file, rebuild Apache configuration file, then restart Apache.
     
  3. Tonic-_-

    Tonic-_- Member

    Joined:
    Oct 16, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Will I notice any change from apache status?
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please feel free to try it out and see. It will cease having an error in /usr/local/apache/logs/error_log when you make those changes about MaxClients needing ServerLimit to be increased, so that's also the indicator.

    Of note, you must have ServerLimit above MaxClients when you set them, so:

    ServerLimit #
    MaxClients #

    Thanks.
     
  5. Tonic-_-

    Tonic-_- Member

    Joined:
    Oct 16, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Well I refreshed my error log and all I see when reboot is
    [Fri Oct 29 18:32:08 2010] [warn] WARNING: Attempt to change ServerLimit ignored during restart

    pre_main_global.conf is setup like so

    ServerLimit 1000
    MaxClients 1000

    Did everything. o.o
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please open a ticket if you did run the distiller, rebuild and restart commands I indicated previously and it still isn't setting that limit. You can open a ticket using WHM > Support Center > Contact cPanel or using the link I have in my signature.

    Also, which MPM are you using for Apache and is it currently Apache 2.0 or 2.2 now?
     
  7. Tonic-_-

    Tonic-_- Member

    Joined:
    Oct 16, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Well i ran all the commands, etc.

    I am running apache 2.2.16 with MPM Prefork
     
  8. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you tried:

    WHM > Service Configuration > Apache Configuration > Global Configuration

    ServerLimit
    MaxClients
     
  9. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    ServerLimit is only in EDGE and CURRENT 11.28 and this client is on STABLE 11.26 per the ticket. On 11.26, only MaxClients is in that area. STABLE will not be pushed to 11.28 until around November 17, 2010 per the release schedule.
     
  10. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator

Share This Page